Paperspace setup help

(Mark Ryan) #83

Thanks - your diagnosis (that the script broke at the unzip step) and recommendation (to complete the missing parts of the script manually in an ssh session) was exactly right. After completing the missing steps in the script and restarting the paperspace env, I was able to get jupyter notebooks going in a browser and all the libraries were there. Thanks!

(Jeremy K) #84

Ok thanks


The curl | bash command breaks after 10 minutes, I tried to restart the machine and the machine cannot restart, I then have to delete the machine and pay the fees. I’ve now created a new machine and the bash command still does not run.

(corey) #86

This helped me too. I ran things mostly one after the download of . Now the notebook is running.

(Tom Brown) #87

I had problems as well. Did not finish first time through. I manually walked through each of the steps by hand.


I just signed up on paperspace. You can use this referral code to get a $10 discount:

Share your referral code:

Please do other users a favor and respond to this post and say when you have used it, because it can only be used once.

(emsart) #89

@cedric : shutting down any VPN process and starting over with a new account solved the credit card issue.

(Radi) #90

I am sorry for the confusion.

If you run the script using the curl | bash will NOT work.

if you run the setup line by line it will work.

(Radi) #92

Hi Dan, would you please look at that curl | bash and see why it breaks on the VMs?

(Ryan) #93

I was also having trouble with not being able to connect to the Jupyter notebook after running the script. But then ran through the setup line by line and it is working now.

(emsart) #94

@ryan so you recommend to run it line by line, is that it?

(Ibrahim Khalil) #95

I suggest try to find out where it breaks… from the various replies and my case included, it breaks at the unzip. So you might need to run it line by line after unzip. But see for yourself where it breaks

The change in Jupiter config won’t work if you do it line by line. I used VIM to add the two amendments in explained here Paperspace setup help

when running line by line, NVIDIA amd64.deb didnt work earlier saying fetch keys first. So I ran the fetch keys statement followed by sudo dpkg amd64.deb statement.

(Ryan) #96

I agree with @financepk. I would say to run the script first and then, if it doesn’t work, find out where by running line by line. For me, it seemed like it didn’t add the Anaconda path to my PATH variable. But all I did was re-run those same lines from the script and it seemed to work then.

(emsart) #97

@ryan @financepk It worked !, thanks !!

(Tim) #98

Something I’ve found very useful already is using the Paperspace API and specifically their handy terminal client for starting and stopping machine instances:

The instructions there are quite straight forward, you have to have Node.js v4+ installed on your computer, install using the node package manager (npm) and then you have access to their handy paperspace client which you can easily use from the command line to start and stop machine instances (among a lot of other things, see:

Unfortunately you have no handy blue bar to remind you to shut down your machine when you’re done, however I find it much faster than using their web interface.

(Jeremy Howard (Admin)) #99

I just created a new instance and ran the script from scratch. It worked without me needing to make any changes. I ran it via ssh rather than the browser console.

I’ve made some changes to the script now to hopefully make it easier to avoid and debug problems:

  • All sudo commands are at the start, so hopefully you’ll only need to enter password once
  • I’ve added more flags to apt to ask it to not request any confirmation
  • I’ve put a couple of set statements at the top to print what it’s doing as it goes, and to stop if there’s an error.

(Radi) #100

That might be the issue, I ran it in the browser per your instructions in the video :slight_smile:

Thank you for making those changes. Would you please run that in the browser and confirm that the changes fix the issue?

(ecdrid) #101

Why will it make a difference ?

We are still running the same script on the same machine except some defaults differing…

(Mark Ryan) #102

I was able to use postal code for Canadian credit card with Paperspace by omitting space between parts - so Santa Claus’s postal code is H0H0H0 , not H0H 0H0

(Reshama Shaikh) #103

I ran the updated script, via ssh also (rather than Paperspace console), and it all works well now! :slight_smile: Also, the notebook 1 works too. I’ve updated the paperspace instructions.

cc: @aseem