Paperspace setup help

We’re currently recommending Paperspace as the best option for this course (we’re not affiliated with the company in any way). You can get a $15 credit with the code: FASTAI15 . If you need any help with getting set up on Paperspace, feel free to ask here! The video shows how to set up paperspace from scratch, but that’s no longer necessary - instead, choose the ‘’ paperspace template (instead of the ubuntu template) when you create your instance.

With many thanks to @reshama, here are written instructions for setting up Paperspace. (NB: currently these instructions are still showing the old way to setup paperspace from scratch, so ignore that part)


Hi Jeremy,
There is template on Paperspace (, should choose this over setup you showed in Deep Learning 2: Lesson 1.

You should use the setup script, not the template, at least for now - the template is not up to date and doesn’t use the fastai conda environment.

1 Like

I just used the paperspace configuration script (using the commands line by line as i had downloaded some of the files already) to configure my local machine for pytorch :no_mouth:


Yeah it should work fine for any Ubuntu computer really! :slight_smile:

Just a quick note for any one having trouble connecting to jupyter remotely.
Simply substituting the localhost by the public ip address didn’t work for me for some reason.
I am on a mac.
I managed to connect successfully by using an SSH tunnel instead:

%ssh -N -f -L localhost:8888:localhost:<jupyter-local-port> paperspace@<your-public-ip>

(you will need to enter your paperspace password)
where jupyter-local-port is the port given by jupyter.
In my case it was 8889.

then go to the browser
and use


to get started.


That’s odd - one of the steps in the script is to open the appropriate firewall ports for jupyter. Did you run the whole script, including the line that refers to “ufw” ?

(Your solution is a good one - just wanting to make sure I didn’t mess up the script somehow.)

Hi Jeremy, yes. I even did the sourcing twice. Then added ip = ‘*’ to the jupyter config as well. This was the final attempt that worked.

Hi: I looked into this a bit more. It may have been because the “~/.jupyter” directories were created as root? I did a chown -hR of .jupyter to the local account and restarted the machine. Now i am able to connect using the regular IP.


The script doesn’t create them as root. Perhaps you ran the script as root?

Which one are we choosing? The one is in beta or the stable version image?

1 Like

I guess I’m having the same/similar question about which image should we start from over on Paperspace?

I see two templates over on Paperspace

  • Deep learning MOOC


  • Deep Learning MOOC Pytourch [BETA]


If, I’m not using one of these templates… but this startup script… what base computer configuration will work and be economical?

Looks like the answer may be in the first class video. Starting at about 6 minutes 20 seconds into the video.

I’ll give this a shot in a few hours later today.

… Time Passes …

I don’t seem to be able to make the choices shown in this video without first making a request for the right to do so from paperspace support. Hope to hear more tomorrow.

… Even more time passes …

In my case, I also seem to have problems choosing Ubuntu 16.04 and GPU+ or the P4000. If I choose Umbtu 14.04, I can choose the GPU+ server. I’ve asked for permission to make the same choices you are showing in the video. Hopefully, I’ll hear something tomorrow when they come back from the New Years Holiday.

… Some more time …
So, I have a GPU+ with Ubuntu 16.04. The folks at paperspace would not grant me a P4000.

Hi whyrv,

I’m also on a Mac and experienced the same issue of connecting to Jupyter remotely. I’m not sure how to execute the chown command you used to be able to use the regular IP. Could you share the full syntax? I was thinking something like this:

$ chown -hR paperspace .jupyter

but I can’t find where my jupyter directory is. When I use “ls -a”, I get the results below.

Hi Chrispmaag, Looks like your setup may not be complete. If you setup the machine from scratch using the fastai paperspace configuration script, you should see a “.jupyter” directory in your home and a jupyter config file inside that. I would suggest repeating the configuration again first before attempting to fix anything. Did you get the reboot message from the script?


Thanks, whyrv! I tried running the curl code one more time from the lesson 1 video ($ curl | bash), and this time I was able to get the jupyter notebook to work!


Did anyone face any issues getting permissions from paperspace? I have a mac and selected, as Jeremy did in the video, the Ubuntu 16 image, for which paperspace asked for the reason and a cited fastai - however haven’t been able to get any response in yes/no from them. So wanted to ask, is it ok to go ahead with Ubuntu 14?

Also, I have been trying to launch my paperspace machine and since last night its been on the page “your desktop is connecting”…like forever.
I sent them an email, waiting for response.

It’s not saying you need permission for Ubuntu 16, but for the specific type of server you requested. If you pick the same server as I did (‘GPU+’ IIRC) it shouldn’t need permission.


Thanks Jeremy - for ‘east coast’ M4000 isn’t available and everything else needs permission - switched to ‘west coast’ and mimicked class settings, which worked fine!