Setup problems: AWS


I had that problem, I just installed a virtual machine (Ubuntu) and everything worked meaning, when you open terminal in Ubuntu, do pip install aws-cli, the rest of the commands work. Are you running windows 8/8.1?

(Chamin Nalinda) #962

Threads are actually “bosom friends”. We do lot of mistakes (eventhough we follow the exact same thing/instructions, we tend to run the same command multiple times [eg.]) , and we get in to issues. And our bosom friends are there to help us :smiley:

(Karthik) #963

Did you find a solution. Please help me.

(Anudeep) #967

I ran the command “bash”. And it executed perfectly. But I’m not able to connect to that instance shown in the second picture below.

Can somebody help me out with this.

(Anudeep) #968

Found the solution. openssh was not installed during the installation of the cygwin64 setup. Reinstalled with “openssh net” as ‘keep’ option instead of ‘skip’.

(Anna Shtengel) #969

I have the same issue.

Generally it started with “Premission denied (publickey)” when I try to connect by ssh
along with the error of Failed to add host to the list of known hosts
There’s no file of “known_hosts” in .ssh

*I’ve run chmod 400 on the .pem file as requested before the ssh

(Vijay Kumar) #970

Hi Vivek,
Please give the details of the installation … are you installing the Fast AI part1 2017 or older one… now faster is providing good ami to get installed all these things by default in AWS environment.
please share the details steps.

(Raghavendra) #971

Thanks for sharing, I searching for this type of solution in my aws training, anyway i found the nice information

(Hareesh Gara) #975

When I type bash
the following error shows
$ bash
True line 13: /home/Hareesh Gara/.ssh/aws-key.pem: No such file or directory
chmod: cannot access ‘/home/Hareesh Gara/.ssh/aws-key.pem’: No such file or directory

An error occurred (InvalidAMIID.NotFound) when calling the RunInstances operation: The image id ‘[ami-bc508adc]’ does not exist
Waiting for instance start…

aiter InstanceRunning failed: Max attempts exceeded
usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help
aws help
aws help
aws: error: argument --instance-id: expected one argument
Connect: ssh -i /home/Hareesh Gara/.ssh/aws-key.pem ubuntu@None
What should I do? Could you please help me

(minbaba) #976

There is some trouble with me that I can’t find the fastai image in the Community AMIs.

(Gaurav Rele) #977

Please check if you are in the correct region. I think most of the fastai ami’s i’ve used are in us-west-2 region.


Thank you very much. It’s correct.


As Nell said, you should change the region.

(Gaurav Rele) #980

Can you send me your scripts so that i can test it on my pc? I know a lot of people are facing this problem and would like to solve it as well.

(Jonas G F Pettersson) #981

Did you get any solution for this? I would need to copy the AMI to Frankfurt region

(Venkat Sai) #982

hi guys, when i’m setting up aws, i’m getting this syntax error: $ bash line 2: syntax error near unexpected token newline' line 2:

i downloded from wget wget

can you please help me out.
Thanks in advance

(Benjamin Stevenson) #983

HI there, I’ve just logged on after a very long asbsence to find lots of help that went unthanked! I’m sorry about that. Better late than never I suppose.

Thanks so much!


Hi Guys,

I’ve successfully set up AWS and was able to open a Jupyter Notebook and import Theano & Keras.

I’m having trouble getting set up with the conda environment.

I’m following the instructions on the github… with git cloning the repo and then running conda env update

when I run conda env update, I get this error

Would really appreciate any help! Thank you!


My mistake.

Solved the issue by updating conda to newest version.

(shanjames) #986

Thanks for sharing your opinons. Great Information about AWS Training in Hyderabad