Setup problems: AWS


#987

First of all, the owners of this site should please consider having a set of instructions in text (rather than a video walkthrough) on how to get AWS set up for Windows users. Videos are hard to change after the fact, especially when you want to add special cases or troubleshooting steps (not to mention the fact that you have to continuosly put them on pause when you are trying to carry out steps).

I actually don’t mind transcribing the video and putting the steps on the wiki myself, but unfortunately, I don’t have permissions to do this.

With that said, I have been trying to follow the video steps in getting AWS set up, anyhow.

I attempted to use Cygwin, but I immediately ran into an issue where I was getting a weird error:
C:\users\tolaod\anaconda3\python.exe: can’t open file ‘/cygdrive/c/Users/tolaod/Anaconda3/Scripts/aws’: [Errno 2] No such file or directory

Turns out that Cygwin is probably not a good tool to use after all. So I enabled Windows Subsystem for Linux and installed Ubuntu from the Microsoft Store (as described here: https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/). Note - Ubuntu can take a while to install.

After this, I started up the bash shell on Ubuntu, and created a username / password. Then I ran this:

aws configure

And I got another error:

-bash: /mnt/c/Users/tolaod/Anaconda3/Scripts/aws: c:\users\tolaod\anaconda3\python.exe^M: bad interpreter: No such file or directory

And I’m stuck. It looks like the /mnt/c/Users/tolaod/Anaconda3/Scripts/aws script wants to use c:\users\tolaod\anaconda3\python.exe, but this exe does not exist at this location. How do I get the /mnt/c/Users/tolaod/Anaconda3/Scripts/aws to point to the correct location of python.exe?

Can anyone help?

Edit:

I made some progress by uninstalling Anaconda and reinstalling the Python 2.7 verision of Anaconda for Windows.

I was able to download the setup_p2.sh file (atlhough I got it from http://files.fast.ai/files/setup_p2.sh , not platform.fast.ai as was specfied in the video).

But now, when I run bash setup_p2.sh, I get the following errors:

setup_p2.sh: line 13: /home/tolaod/.ssh/aws-key.pem: No such file or directory
chmod: cannot access ‘/home/tolaod/.ssh/aws-key.pem’: No such file or directory

There is no .ssh folder in my home directory, so it is not clear why the script is looking for this.

Even after creating the .ssh folder in my home directory, I got another error:

An error occurred (VpcLimitExceeded) when calling the CreateVpc operation: The maximum number of VPCs has been reached.

It’s not clear how to resolve this; I have seen the suggestion to go to my AWS console and delete any VPCs that I might have, but I do not have any VPCs set up.

Another suggestion was that I should release any Elastic IPs that I have; I have checked the Elastic IPs in my console, and there do not appear to be any IPs for me to release.

Again, any help would be appreciated.


Problems setting up AWS for fast.ai course
(abhi) #988

I’m really frustrated right now. Please, someone help. I’ve put hours in configuring AWS but now a success. Someone please jump in and help me

❯ bash setup_p2.sh
True

An error occurred (InstanceLimitExceeded) when calling the RunInstances operation: You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit http://aws.amazon.com/contact-us/ec2-request to request an adjustment to this limit.

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start...

Waiter InstanceRunning failed: Max attempts exceeded
usage: aws [options] <command> <subcommand> [<subcommand> ...] [parameters]
To see help text, you can run:

  aws help
  aws <command> help
  aws <command> <subcommand> help
aws: error: argument --instance-id: expected one argument

An error occurred (MissingParameter) when calling the RebootInstances operation: The request must contain the parameter InstancesSet

All done. Find all you need to connect in the fast-ai-commands.txt file and to remove the stack call fast-ai-remove.sh
Connect to your instance: ssh -i /Users/abhimanyuaryan/.ssh/aws-key-fast-ai.pem ubuntu@None
bash setup_p2.sh  13.19s user 2.62s system 2% cpu 11:02.28 total



(bannubabu) #989

Nice Article …Thanks for providing information that was worth reading & sharing

ielts coaching in hyderabad
Machine Learning Course Hyderabad


(Bharath Paulazar) #990

Thank you for this piece of information. It was really helpful and will help many more.Machine Learning Course in Chennai


(Bharath Paulazar) #991

Is There any Availability of a New and updated book ?


(Preethi John) #992

Very informative! I’m learning a lot of stuff from here. Keep sharing more. Click here.


(nishant hegde) #993

for those getting the “ami-bc508adc does not exist” error when running setup_p2.sh, the new fastai image id for p2.xl is ami-951609ec

if you replace this in line 16 in setup_p2 it will run successfully