Problems setting up AWS for fast.ai course


#1

I had posted this issue here, but I have had no responses so far, so I am hoping that I will get better traction with this new topic.

I have been trying to follow the video steps in getting AWS set up.

Initially, I attempted to use Cygwin, but after running into multiple issues, I enabled Windows Subsystem for Linux and installed Ubuntu from the Microsoft Store (as described here: https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/).

I then uninstalled all existing versions of Anaconda and reinstalled the the Python 2.7 verision of Anaconda for Windows, and ran the aws configure command to get the setup process started.

After that, I downloaded the setup_p2.sh file (atlhough I got it from http://files.fast.ai/files/setup_p2.sh , not platform.fast.ai as was specfied in the video) and I then ensured that I had an .ssh directory under my home directory,

But when I ran bash setup_p2.sh, I got the following error:

An error occurred (VpcLimitExceeded) when calling the CreateVpc operation: The maximum number of VPCs has been reached.

It’s not clear how to resolve this; I have seen the suggestion to go to my AWS console and delete any VPCs that I might have, but I do not have any VPCs set up.

Another suggestion was that I should release any Elastic IPs that I have; I have checked the Elastic IPs in my console, and there do not appear to be any IPs for me to release.

Please help - this is blocking me from starting the course.


(William Horton) #2

Check your limits of AWS p2 instances. Your limit might be 0, which would explain why you’re hitting the limit despite having no VPCs.


#3

Thanks for responding, William. Where would I go to check my limits of aws instances?


(Iaroslav Russkykh) #5

https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/ec2-resource-limits.html


#6

Hello Iaroslav,

I checked, and I can see that I have 1 p2.xlarge instance for the Oregon (us-west-2) region (see image below). Any thing else I can do to make the VpcLimitsExceeded error go away? Is there a misconfiguration on my side that I can check? I confirmed that my .aws/config file is pointing to us-west-2.


(Iaroslav Russkykh) #7

i don’t know, but check your running instances, may be you already have one p2-xlarge online


#8

Hello Iaroslav,

From the image below, I don’t think I have any running instances.

This is the url I went to in order to check: https://us-west-2.console.aws.amazon.com/ec2/v2/home?region=us-west-2#Instances:sort=instanceId


(Iaroslav Russkykh) #9

@tolaodejayi one more option: you can start instance manually and install all what you need following this instruction. something like:

ssh <instance>
mkdir src
cd src
wget https://repo.anaconda.com/miniconda/Miniconda3-latest-Linux-x86_64.sh
bash Miniconda3-latest-Linux-x86_64.sh
cd
git clone https://github.com/fastai/fastai
cd fastai
conda create --name fastai python=3.7
source activate fastai
pip install -e .[dev]
jupyter notebook

(Akshitha Gokula) #10

I Have Created a an Instance How Can Get Duplicate same Instances in simple way