Setup problems: AWS

Thanks for sharing, I searching for this type of solution in my aws training, anyway i found the nice information

@ozkansafak
When I type bash setup_p2.sh
the following error shows
$ bash setup_p2.sh
rtbassoc-c3b916a8
True
setup_p2.sh: line 13: /home/Hareesh Gara/.ssh/aws-key.pem: No such file or directory
chmod: cannot access ‘/home/Hareesh Gara/.ssh/aws-key.pem’: No such file or directory

An error occurred (InvalidAMIID.NotFound) when calling the RunInstances operation: The image id ‘[ami-bc508adc]’ does not exist
Waiting for instance start…

aiter InstanceRunning failed: Max attempts exceeded
usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help
aws help
aws help
aws: error: argument --instance-id: expected one argument
securityGroupId=sg-1b2f0970
subnetId=subnet-ede17285
instanceId=
instanceUrl=None
Connect: ssh -i /home/Hareesh Gara/.ssh/aws-key.pem ubuntu@None
What should I do? Could you please help me

There is some trouble with me that I can’t find the fastai image in the Community AMIs.

Please check if you are in the correct region. I think most of the fastai ami’s i’ve used are in us-west-2 region.

Thank you very much. It’s correct.

As Nell said, you should change the region.

Can you send me your scripts so that i can test it on my pc? I know a lot of people are facing this problem and would like to solve it as well.

Did you get any solution for this? I would need to copy the AMI to Frankfurt region

hi guys, when i’m setting up aws, i’m getting this syntax error: $ bash setup_p2.sh
setup_p2.sh: line 2: syntax error near unexpected token newline' setup_p2.sh: line 2:

i downloded from wget https://raw.githubusercontent.com/fastai/courses/master/setup/setup_instance.sh wget https://raw.githubusercontent.com/fastai/courses/master/setup/setup_p2.sh

can you please help me out.
Thanks in advance

HI there, I’ve just logged on after a very long asbsence to find lots of help that went unthanked! I’m sorry about that. Better late than never I suppose.

Thanks so much!

Hi Guys,

I’ve successfully set up AWS and was able to open a Jupyter Notebook and import Theano & Keras.

I’m having trouble getting fast.ai set up with the conda environment.

I’m following the instructions on the github… with git cloning the repo and then running conda env update

when I run conda env update, I get this error

Would really appreciate any help! Thank you!

My mistake.

Solved the issue by updating conda to newest version.

Thanks for sharing your opinons. Great Information about AWS Training in Hyderabad

First of all, the owners of this site should please consider having a set of instructions in text (rather than a video walkthrough) on how to get AWS set up for Windows users. Videos are hard to change after the fact, especially when you want to add special cases or troubleshooting steps (not to mention the fact that you have to continuosly put them on pause when you are trying to carry out steps).

I actually don’t mind transcribing the video and putting the steps on the wiki myself, but unfortunately, I don’t have permissions to do this.

With that said, I have been trying to follow the video steps in getting AWS set up, anyhow.

I attempted to use Cygwin, but I immediately ran into an issue where I was getting a weird error:
C:\users\tolaod\anaconda3\python.exe: can’t open file ‘/cygdrive/c/Users/tolaod/Anaconda3/Scripts/aws’: [Errno 2] No such file or directory

Turns out that Cygwin is probably not a good tool to use after all. So I enabled Windows Subsystem for Linux and installed Ubuntu from the Microsoft Store (as described here: https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/). Note - Ubuntu can take a while to install.

After this, I started up the bash shell on Ubuntu, and created a username / password. Then I ran this:

aws configure

And I got another error:

-bash: /mnt/c/Users/tolaod/Anaconda3/Scripts/aws: c:\users\tolaod\anaconda3\python.exe^M: bad interpreter: No such file or directory

And I’m stuck. It looks like the /mnt/c/Users/tolaod/Anaconda3/Scripts/aws script wants to use c:\users\tolaod\anaconda3\python.exe, but this exe does not exist at this location. How do I get the /mnt/c/Users/tolaod/Anaconda3/Scripts/aws to point to the correct location of python.exe?

Can anyone help?

Edit:

I made some progress by uninstalling Anaconda and reinstalling the Python 2.7 verision of Anaconda for Windows.

I was able to download the setup_p2.sh file (atlhough I got it from http://files.fast.ai/files/setup_p2.sh , not platform.fast.ai as was specfied in the video).

But now, when I run bash setup_p2.sh, I get the following errors:

setup_p2.sh: line 13: /home/tolaod/.ssh/aws-key.pem: No such file or directory
chmod: cannot access ‘/home/tolaod/.ssh/aws-key.pem’: No such file or directory

There is no .ssh folder in my home directory, so it is not clear why the script is looking for this.

Even after creating the .ssh folder in my home directory, I got another error:

An error occurred (VpcLimitExceeded) when calling the CreateVpc operation: The maximum number of VPCs has been reached.

It’s not clear how to resolve this; I have seen the suggestion to go to my AWS console and delete any VPCs that I might have, but I do not have any VPCs set up.

Another suggestion was that I should release any Elastic IPs that I have; I have checked the Elastic IPs in my console, and there do not appear to be any IPs for me to release.

Again, any help would be appreciated.

I’m really frustrated right now. Please, someone help. I’ve put hours in configuring AWS but now a success. Someone please jump in and help me

❯ bash setup_p2.sh
True

An error occurred (InstanceLimitExceeded) when calling the RunInstances operation: You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit http://aws.amazon.com/contact-us/ec2-request to request an adjustment to this limit.

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start...

Waiter InstanceRunning failed: Max attempts exceeded
usage: aws [options] <command> <subcommand> [<subcommand> ...] [parameters]
To see help text, you can run:

  aws help
  aws <command> help
  aws <command> <subcommand> help
aws: error: argument --instance-id: expected one argument

An error occurred (MissingParameter) when calling the RebootInstances operation: The request must contain the parameter InstancesSet

All done. Find all you need to connect in the fast-ai-commands.txt file and to remove the stack call fast-ai-remove.sh
Connect to your instance: ssh -i /Users/abhimanyuaryan/.ssh/aws-key-fast-ai.pem ubuntu@None
bash setup_p2.sh  13.19s user 2.62s system 2% cpu 11:02.28 total


Thank you for this piece of information. It was really helpful and will help many more.Machine Learning Course in Chennai

Is There any Availability of a New and updated book ?

Very informative! I’m learning a lot of stuff from here. Keep sharing more. Click here.

for those getting the “ami-bc508adc does not exist” error when running setup_p2.sh, the new fastai image id for p2.xl is ami-951609ec

if you replace this in line 16 in setup_p2 it will run successfully

Hi,

I am also having the same issue regarding AWS setup and found the best answer from this site.