No module named 'fastai'

Hi All,
I am running lesson1 on my local linux system. i followed below step:

  1. i clone course-v3 directory.
  2. then activated course-v3 environment
  3. from there i was running jupyter notebook
  4. Now when i tried to run this cell:

from fastai import *
from import *

It is giving error that "No Module Name ‘fastai’ "

I tried some previous forum discussion on it:

but it didn’t resolve the issue.
Please, somebody help me to come out this error.

1 Like

I guess you need to install the library into the correct environment. From your description, it seems that you only have notebooks but not the library itself. Please check the repo, it contains required instructions:

It got working for me,

i have followed this forum thread:

then downloaded latest course-v3 and extract the folder
then i put the extracted folder inside fastai environment:

then run conda update
after this jupyter notebook is also working

I’m having a similar problem. I’m also trying to run lesson 1 on my local machine. I’ve followed the instructions to install the library.

Oddly, I’m getting an error on line 2

         1 from fastai import *
--->     2 from import *

ImportError: No module named vision

Can you walk me through what might be happening here?


I may be wrong, but in previous sessions of the course the library and the course were in the same repo - so you could clone the repo and use the library.
Currently the course and the library exist in separate repos. So I installed fastai v1 at first and then cloned the repo with the course.


you can refer this thread:

I used these steps, and error got resolved for me:

  1. Open terminal

  2. Navigate to anaconda3
    cd anaconda3

  3. update conda
    conda update conda

  4. Navigate to conda env section and create new environment named fastai
    cd envs
    conda create --name fastai

  5. make fastai environment as current working directory
    cd fastai

  6. clone github repository of course-v3
    git clone

  7. make course-v3 as current working dir
    cd course-v3

  8. open jupyter notebook
    jupyter notebook

  9. Click New->Terminal in Jupyter, then type:
    conda install -c fastai fastai
    this step will install all required libraries.

after this you can update conda environment ( for me it was updated)


I got up to step 8: I opened a new jupyter terminal, but it would not allow me to type or paste any code. Therefore i could not do step 9. How do I resolve this?

I followed these instructions, and it seems to have damaged my anaconda environment. The conda command no longer works. How do I fix this?