Beginner: Beginner questions that don't fit elsewhere ✅

“new stuff” is a bit vague to provide specific advice on.
You should get most of what you need from… GitHub - bencoman/paperspace-setup: Setup a paperspace instance for fastai

1 Like

Its not clear what you mean by “Lesson 10”.
Lesson 8 was the last lesson.

1 Like

You’ve encoded the predicted-seven incorrectly. The meaning of prds is the “probability that it is a 3”, so 0.9 is high probability of a 3 and high probability of a 7 is 0.1.

Consider closely this paraphasing from 04_mnist_basics.ipynb:

  • high confidence of a 3 ==> (0.9)
  • slight confidence of a 7 ==> (0.4)
  • good confidence of a 7 ==> (0.2)
trgts  = tensor([1,0,1])
prds   = tensor([0.9, 0.4, 0.2])

For determining the 0.2, ignore the “although incorrect”. That statement refers only to the 0.2 not matching the “1” in the third element of trgts.

So basically low confidence score indicates not 3

Not exactly. Low confidence is values near 0.5, which indicates the model is “not sure” if its a 3 or 7.
High confidence is the two far ends, 0.9 or 0.1, being a high confidence of 3 or 7 respectively.

1 Like

not sure what ive done here, any help would be great.

i followed the video and ended up with this

hi jeremy, followed your video and ended up with this after installing wsl and pasting the git

I’m not sure where to find the video you’ve watched, but a heads up just in case: you’re not currently inside of your WSL environment, powershell is still on your regular windows environment.

Here’s a useful stack overflow answer to your error (can be found by just searching the error string: “the term ‘git’ is not recognized as the name of a cmdlet…”)

This is happening either cause you’ve not installed git, or you haven’t set the path. You can install git here:

https://git-scm.com/book/en/v2/Getting-Started-Installing-Git

And there are instructions to setting the path in the stack overflow answer above.

1 Like

Lesson 4. Just looked it up now.

1 Like

I’m following the Fast AI program in this page: https://course.fast.ai/
On lesson 4 (Practical Deep Learning for Coders - 4: Natural Language (NLP)) we have a video which shows a code based on Chapter 10 of the book (https://www.amazon.com/Deep-Learning-Coders-fastai-PyTorch/dp/1492045527).
Chapter 10’s code is located here: fastbook/10_nlp.ipynb at master · fastai/fastbook · GitHub

I’m trying to find a way of downloading the above ipynb code.
Can you help me with some guidance?

thanks Dylan, slowly figuring out git and wsl environment, slowly but surely ill get there, all brand new!

thanks again ill check out the stack link!

You can click on “Raw”, the Right-Click > Save As…
image

Make sure the extension ends up “.ipynb” and not “.txt”…
image

Ahhh, I think I just got it. I may have had a similar question when I started about “How to get a blank workspace on paperspace”. You can get an empty the workspace from the terminal doing…

$ rm -r /notebooks

but actually in the short term, the advice was to not do that, and just create a folder “MyStuff”.
This is makes it easier to template off fastai notebooks.

1 Like

It worked. TY!

1 Like

No idea if I’m late to the party but please help me.

I’m unable to run the vision learner using any architecture(resnet 18 / 34).
To be honest I don’t even know what most of this means, I only tried to replicate what was there in the official lesson 1 Notebook on kaggle.




Uploading: Screenshot from 2022-09-25 22-26-37.png…

Hey, it’s super hard to find the error for your problem with the amount of information you gave. In order to do so you should at least show how you created your DataLoaders and Learner, better even share your whole notebook :slight_smile: .
Generally: I think I encounterd that kind of error message with loss/metric issues, so the loss/metric function your learner is using doesnt fit the data you have or problem you want to solve.

How does the validation set function , i mean we

valid_pct=0.2

by default in fast.ai but where do i know how is this used ? it seems like a black box to me.
Can some one please explain as to how this works and where do i get to view how the validation set is used in the model?

Thanks for the suggestions @benkarr , I don’t know how to share the notebook directly thus I’ve uploaded all the screenshots if that could be of any help.

In short, the validation set is used to report the performance of the model (as per the metrics that you choose, error rate is the default I think). It is not used for training the model.
You can do:

splits = RandomSplitter(seed=42)(items)
splits

Where items is any list-like object. You will see the two sets it creates.
Hope this helps.

1 Like

You could upload your notebook to Github or kaggle and post a link here.

I couldn’t find any obvious mistake scanning your code and since you have all the code the original notebook has (assuming we both didn’t miss something) that should work fine…
It seems that you are using a local setup, so a way to aproach this could be to actually do the uploading to kaggle part and check if it works there to pin it to the code or the evnironment (and I could also have a closer look :smile:)

Thanks a lot for bearing with me.
It appears to be as you pointed and the fault may actually lie with my local system as the result were similar to jeremy’s in the kaggle notebook.

https://www.kaggle.com/monarch252001/fastai-lesson-1/edit

How should I proceed from here? I’ve already tried reinstalling the fast AI libraries on a new conda env but the results were still the same.

hi @mozart_25, Strongly concur with @benkarr that you should start your fastai journey using the online services, as well as your local install. Its much easier to assist you. You are then also able to compare your experiences between the two enrionements to help isolate problems.

You do need to set your kaggle notebook to “public” so we can see it. At the moment I get a 404 error.

Regarding your local environment. Did you set it up according to the Live Coding walkthroughs?

Just as a point of reference, could you do this check…

import fastai
fastai.__version__
2 Likes