Pytorch 1.0 is officially released

Title pretty much says it all.

Should be able to install on windows(though) I haven’t tried yet.

1 Like

Let us know if you get this installed on Windows and can run the notebooks. Hoping for the best (and one more reason to upgrade to a Surface Book in the near future).

Good luck!

1 Like

Looks like there will be some kinks to iron out for Windows.

For installing on Windows:

conda create -n fastai_v1 python=3.6
activate fastay_v1
conda install -c pytorch pytorch-nightly cuda90 (match the cuda version to your installation)
conda install -c fastai torchvision-nightly
conda install -c fastai fastai

After this I had issues with Jupyter notebooks - they would start in a python 2 environment and throw the error
[sprintf] expecting number but found string
When opening notebooks. This was fixed with

conda install ipykernel
conda install jupyter

Now notebooks open with the correct kernel.

When trying to run Lesson 1 - Pets I get an error related to the regular expression used. returns NoneType.

When trying to run Lesson 3 - Camvid I get some weird pickling error deep in the multiprocessing when running data.show_batch(2, figsize=(10,7)).

PicklingError: Can't pickle <function crop_pad at 0x00000243D92FB268>: it's not the same object as

Will report back if I figure things out.


Regarding the regular expression error in Lesson 1, the fix is simple. Change your regular expression to:

pat = re.compile(r’\\([^\\]+)_\d+.jpg$’)

After that when I try to use data.show_batch(), it runs into the same pickling error you get for lesson 3:

PicklingError: Can’t pickle <function crop_pad at 0x000001F60F287158>: it’s not the same object as


There are also now CUDA 10.0 builds in conda. Nice!

1 Like

I get the following error when I use the regex you suggested:

SyntaxError: invalid character in identifier

and it points to the ’ after the r

I didn’t realize that the escaped backslashes disappeared on the post. I’ve edited my comment to match the actual regex needed.

I’m seeing the pickling error too.

Yup the pickling error on windows is going to be tricky to fix. Might take a few weeks…


Q: Peter Piper pip-ed a peck of pickled pthreads.
A peck of pickled pthreads Peter Piper pip-ed.
If Peter Piper pip-ed a peck of pickled pthreads,
Where the heck is the pickled pets that Peter Piper python-ed?

A: Peter Pipers, please pause two weeks to pip a peck of pickled pthreads.


I’m able to get the lesson-1-pets network properly trained on Windows, with the latest fastai.
Thanks for the quick fix.

1 Like

Hello, I tried to update fastai from conda today, but I’m having issues with pytorch-1.0 linked torchvision. Seems as though there’s no torchvision-nightly in ‘-c fastai’ and the torchvision package there is linked against pytorch 0.4.1. Are you guys seeing the same or have I somehow screwed up my installation.

I’m on arch linux host, anaconda53 installed.

Kind regards,


Found this one, probably explains the situation better then my explanation above. And the ‘torchvision’ there pulls in pytorch 0.4.1 if I try to install is.

You didn’t get the pickle error?

PicklingError: Can’t pickle <function crop_pad at 0x00000283DBF51840>: it’s not the same object as

I’m still getting that error, so can’t run the notebooks locally on Windows 10, although PyTorch and fastai newest versions installed.

I’m getting past that error with Python 3.7 and FastAI 1.0.37.
This is the steps I’m using for my Conda environment. Windows 10.
conda create -n fastai-3.7 python=3.7
conda activate fastai-3.7
conda install pytorch torchvision -c pytorch
conda install -c fastai fastai
conda install nb_conda_kernels
python -m ipykernel install --user --name fastai-3.7 --display-name “Python (fastai-3.7)”
conda install ipywidgets


Worked for me – Thank you!!!

kaggle has been updated

1 Like

Major breakthrough for Windows. Big thanks. Your commands have gotten me passed the pickle problem. Pets is in the process of running to end. So far so good.

Do you know what fixed the pickle issue?

I don’t @bsalita. I know it was related to multi-threading. Not sure if it was properly fixed or multi-threading avoided for now. It does feel on my Windows machine that the GPU stuff flies - but it is very slow in the CPU parts - but subjective - I keep meaning to go back to my Linux VM and do a proper comparison.

Thanks again for the fix, really appreciated :slight_smile: