Platform: Paperspace and Gradient ✅

(Jeremy Howard (Admin)) #1

Any questions related to Paperspace / Gradient can be posted here.


Note that this is a forum wiki thread, so you all can edit this post to add/change/organize info to help make it better! To edit, click on the little pencil icon at the bottom of this post. Here’s a pic of what to look for:

discourse_edit_btn


4 Likes

Paperspace - Heats up CPU
FAQ, resources, and official course updates ✅
Lesson 1 Discussion ✅
Paperspace - Heats up CPU
(Roberta) #2

I already have a Paperspace “Core” machine set up with the previous course version, can I use that instead of creating a new “Gradient” instance?

0 Likes

(Jeremy Howard (Admin)) #3

Gradient is easier - but you’re welcome to use the core platform if you prefer.

3 Likes

(Roberta) #4

Thanks @jeremy I’ll use Gradient for now for the course, then think about choosing one way or another, I have a project up on the Core machine that I’m plugging away at.

1 Like

(Daniel) #5

Dan here from Paperspace. Feel free to ping me with any questions you have! We love this course and want to be helpful in any way we can.

5 Likes

(Christine Etoke) #6

How long does it usually takes for a Notebook to spin up ?
I canceled mine after 15mn.

0 Likes

(Daniel) #7

@Chris237 It should only take a few seconds to spin up. We’ll take a look asap.

0 Likes

(William Horton) #8

Just a note: I’m checking out Gradient and I was running the lesson1-pets notebook, and it seemed to get stuck on this line: help(untar_data). The kernel was still saying it was running after several minutes, even after the progress bar got to 100%. Not sure what caused that exactly, but I just wanted to report that if you hit that situation, I was able to just hit the stop button, run the cell again, and proceed through the rest of the notebook.

0 Likes

(Dillon (Paperspace)) #9

We are seeing that as well. Seems to just be taking a while to untar the image in the /storage persistent data directory. If it looks frozen after a few minutes you can try to start the notebook again.

1 Like

#10

anyone else getting an import error when trying to import from fastai? Getting the following error:

ImportError: libcuda.so.1: cannot open shared object file: No such file or directory

0 Likes

(William Horton) #11

If it helps you track things down, the trace I saw when I killed the cell had to do with chowning the files. Could be some kind of permissions issue.

0 Likes

(Dillon (Paperspace)) #12

are you using an instance that supports a GPU? If you are on a C instance type it won’t have CUDA which is an NVIDIA GPU library.

1 Like

(Dillon (Paperspace)) #13

thx! can you share a screenshot or logs of what you are looking at? we are trying to track it down

0 Likes

(William Horton) #14

Sadly I lost the logs because I re-ran the cell, should’ve saved them. I went back to do it now, and it looks like it’s working.

I could’ve sworn that before it wasn’t actually going to /storage/, that might’ve been the change?

0 Likes

(William Horton) #15

So I just did a fresh run to try to replicate, and sure it enough it went to the other location:

But it was really fast this time–it didn’t hang.

0 Likes

(Jesús Pérez) #16

Hello! I already have a VM with fastaiv07 (which i want to maintain), which will be the steps to create a 2nd environment where to install the last version of fastai?

0 Likes

(Nathan Hubens) #17

Hi !
Is the promo code only for ‘in-person students’ ? Because it gives me an error when I want to claim it.

I’m logged in with the same mail address than on the forum, added my credit card and everything is set up following the instructions but I get :

Error! User cannot claim promo code

0 Likes

(Abhay Varma) #18

Hi @dkobran, hope you are well?

I am using Paperspace VM, P4000.

How would I configure the new course (which is to be configured on Gradient) on the same machine?

Please let me know.

Hope my question is not ambiguous.

Thanks,
Abhay Varma

0 Likes

(Sergiusz Bleja) #19

I was in the same situation with a paperspace P4000 set up for the previous course. When I tried running the first notebook I realised it used the CPU because it took such a long time, when I saw on Jeremy’s notebook it only took 30 seconds for one epoch. It turned out that you have to upgrade the CUDA version to 9.2 (I had 9.1). It was a little bit messy, I mainly followed the instructions here: https://medium.com/@abhiksingla10/installing-cuda-9-2-and-cudnn-7-1-on-ubuntu-16-04-d194cee27cba .

In summary you have to install/upgrade three things:

  1. Nvidia drivers: NVIDIA Drivers 396.54 worked for me with CUDA 9.2
  2. CUDA 9.2
  3. CUDNN 7.1

I hope that helps!

1 Like

(Fernando Melo) #20

Hi Dan, I´ve been using paperspace for the last six month´s and I ´d like to keep using paperspace for this new fastai v3 course. I´ve tried many times to set a new machine, but I´m having lots of problems every time I create a new machine. I wish I could have a step by step tutorial that could work for fastai v1.0.11, which is the more stable version today. Otherwise, I believe myself and many old customers will end up changing to google and AWS … Thanks

0 Likes