Platform: Crestle ✅


(Jeremy Howard (Admin)) #1

This is for discussion of Crestle.ai, which is currently in testing. If you’d like to help test, you’ll get free GPU use until Monday! Please don’t share this website outside of this course category - the Crestle team are being kind enough to let us all be their first users. (Note that previous versions of the course recommended crestle.com, which will continue to run, but does not support fastai v1 or course-v3. crestle.ai is a nearly from-scratch rewrite.) To get started, click here:

https://course-v3.fast.ai/start_crestle.html

The following folks are here from Crestle to help:

We’ve done some limited internal testing here, but please be aware that it’s an early version so it’s possible that things might disappear, servers might not start properly, etc - so don’t rely on it for vital stuff! If you see any problems at all, do let us know. Be sure to describe as closely as you can what you did, and what happened, and include any error messages you see. You can provide your signup name to one of the Crestle team over private message if needed.


FAQ, resources, and official course updates ✅
Lesson 2 In-Class Discussion ✅
(Neeraj Kashyap) #2

Hello fast.ai community, looking forward to supporting you on crestle.ai! :slight_smile:


(Neeraj Kashyap) #3

Note that our instances are free to use at the moment while the product is in alpha. They will remain free until at least Monday.


(Jonathan McGowan) #4

Very excited to be taking the class with you all :raised_hands:
I’m in group 44 if you want to come say hello or ask questions in person!


(Akshay Sharma) #5

Hello everyone! Looking forward to providing the community with a reliable and affordable infrastructure to run the fast-ai v3 course.


#6

i just followed the setup instructions. it’ very easy to setup and run notebooks. thanks!

one question: how do i upload data from local computer please?

i tried scp but don’t know what username and destination_host should i use

thanks!


(Jeremy Howard (Admin)) #7

Click the ‘upload’ button in jupyter notebook.


(Akshay Sharma) #8

Upload button is the best way to do it from your local computer.

If you have the data on s3 or some other server you can go in to terminal and use wget (as described here https://www.crestle.ai/faq)


#9

that works well, the only thing how can i view hidden folders like .kaggle using jupyter? not a big problem as i can upload and move the file later, but would be nice to upload direct to correct folder. thanks!


(Akshay Sharma) #10

Viewing hidden files is a bit difficult without changing how we launch Jupyter (https://github.com/jupyterlab/jupyterlab/issues/2049). Today we have locked that up so that it can be launched with the default setting as your home directory contains a few hidden directories that should not be displayed in Jupyter (example: .anaconda/.jupyter/.datasets etc).

In the future we will provide the option for allowing you to change the Jupyter setting if you want to view the hidden files as well.
At the moment the approach you suggested works best - upload and then move it from a hidden directory to a visible directory.

Thanks!


(George John) #11

I signed up but I’m not seeing the part1v3 notebooks…

When I launch jupyter I can navigate to courses/fastai/courses/dl1 and the files in there are 9 months ond

Are the notebooks for v3 of the course available somewhere? Did I need to signup in some other way to indicate I’m a student enrolled in v3?


(Jeremy Howard (Admin)) #12

@gjohn maybe you are accidentally going to crestle.com instead of crestle.ai?


(George John) #13

right - thanks!


(Frederick Kautz) #14

@gjohn, if you are on crestle.ai instead of crestle.com and are having problems, let us know!

Thanks @jeremy for getting to this so quickly!


(vibhor sood) #15

I tried using crestle for fastai I am getting following errors as shown in attached error screens.

1.There is no GPU available —> error_1
2.Can’t type anything on terminal its stuck —> error_2
3.Kernel stuck notebook not working —> error_3

Please rectify the same.


(Jonathan McGowan) #16

Hi @vibhorsood ,
We’ve taken a look at your issue and replied to you via email. The issue should be resolved now but please let us know if you continue to have this problem


#17

i have downloaded 30GB tar file which i try to extract, however i run into out of storage error. is there a way to get more storage? thanks!


(Akshay Sharma) #18

@miwojc - we have currently limited the capacity on the disks to 75GB for optimal usage. 36 GB out of this is taken by fast.ai v3 datasets.

Are you trying to import a different dataset? If it is fast.ai dataset it will be located under your home directory:
~/.datasets/

If it is indeed a different dataset my suggestion is that move this to /tmp directory and expand it there. However, this will not be backed up for you. So treat this as a temporary solution.

Another thing you could do (not advisable) is that you should try clearing up some space by removing directories under ~/.datasets -
These will be recreated when you run the relevant notebooks later (although will take a lot of time to download).
Not an optimal choice.

If you are looking for something more general purpose with a bigger storage (although not free) you should check out crestle.com which gives you higher data storage (but not fast.ai compliant atm)


#19

thank you for the quick answer @shad0wfax
i was just about to try the solution you proposed however i cannot open Jupyter notebook in the new tab. see screenshots attached. i tried friefox (which was working so far) and chrome. the same issue for both browsers.



(Akshay Sharma) #20

@miwojc - looking into it.

Can you in the meantime - logout and login again and start Jupyter?