Paperspace setup help


(aaron) #41

Thanks Jeremy for advice to ssh in from my local machine. I think the installation script failed around these lines:

sudo apt install unzip -y
sudo apt -y upgrade --force-yes
sudo apt -y autoremove

based on the lack of a symbolic link to ~/data in my ~/fastai/courses/dl1/ dir which should have existed by this point.

This was the second machine I’m trying the installation on - hopefully someone can avoid the double charge by reading the forum!


(Jeremy Howard (Admin)) #42

@dillon is from paperspace, so I’ll ping him here to make sure he’s aware that some people are finding running a script through the web-based terminal seems a little unreliable.


(Jeremy K) #43

Question about paperspace. So for the monthly billing, what if I don’t use my machine for a month. Will I still be charged the monthly rate even if I did not launch my machine that month?


(Sarada Lee) #45

I assumed you are going to use the Hourly Plans.

Below is the extracted from Paperspace website:
“With an hourly machine, you are charged a flat fee for storage plus an hourly rate for your usage. Hourly usage is prorated down to the millisecond. At signup/machine creation, you are charged the monthly storage fee. One the next billing cycle, you are charged for your usage during the previous month + the storage fee for the next month.”


(Cedric Chee) #46

@init_27 I came here to ask the same question as I couldn’t find anywhere in the part 1 v2 forum for the steps to setup Google Cloud Platform (GCP). Currently, a few of them from the AI Saturdays community are starting to ask for the correct (tested) way to do this. One of them used the old script from part 1 v1.

@ecdrid Do you have a exact link to this “previous version of this course”? What are the tweaks that we need to make it work for part 1 v2? Thank you.


(Cedric Chee) #47

Yes, I am having trouble making a payment on Paperspace. Credit card got declined. I received this error while trying to create a new machine. I have verified that I entered my credit card details correctly.

Billing/account problem: All attempts at charging via Stripe so far have failed (3).

Paperspace support response:

Paperspace payment processor appears to have blocked your charges because it is not able to identify your IP address. This can happen if you’re using a VPN or other IP address anonymizer, but also occasionally if you are behind a corporate or university firewall. We recommend disabling any of these if possible and trying again.

Another problem is:

Billing/account problem: Account has too many failed Stripe charge attempts (3 of 4)

Right now, I am stucked at this level.


(Ibrahim Khalil) #48

I am trying to sign up from Canada but paperspace isnt allowing my credit card saying the zip code (in Canada, we have postal codes) is wrong. However, I can see three transactions from paperspace in my credit card account as well as three reversals (i tried three times)


(Radi) #49

When I run jupyter notebook I keep getting No web browser found: could not locate runnable browser.

First time working with jupyter so I need all the help you guys can give me.


(Ibrahim Khalil) #50

Tried multiple times with Visa even talking to the bank (the bank said we aren’t holding it. Its approved from our end) but didn’t work. Went through smoothly with MasterCard. Try a different card.


(Cedric Chee) #51

Can you try starting the Notebook server without opening a browser to see if that helps?

http://jupyter.readthedocs.io/en/latest/running.html#how-do-i-start-the-notebook-server-without-opening-a-browser

$ jupyter notebook --no-browser

(Cedric Chee) #52

I see. Thanks for shedding some light to my own issue. I have tried with Visa and Master Card yesterday and both failed. :thinking:


(ecdrid) #53

(Radi) #54

That worked, however, I am not able to open the notebook

http://65.49.81.182:8888/?token=token

when I copy the url from the console and replace localhost with my VM IP, it never loads the notebook page


(Cedric Chee) #55

Good to hear it worked.

it never loads the notebook page

Meaning? What you are seeing is just a blank page?

I think you should check your server (Paperspace? AWS?) network and security settings. I suspect something is blocking your network connection. The usual suspect is in the firewall configurations, like firewall port is not open, Jupyter Notebook bind to the wrong local/internal IP address or the need to do port forwarding for the Jupyter server, etc.


(Radi) #56

@cedric I get

This page isn’t working
184.105.4.134 didn’t send any data.
ERR_EMPTY_RESPONSE

I used paperspace. I don’t know if there are any security settings to check.

MACHINE TYPE: GPU+ HOURLY
REGION: NY2
PRIVATE IP: 
10.64.9.203
COPIED
PUBLIC IP: 
184.105.4.134
COPIED
RAM: 30 GB
CPUS: 8
HD: 0 BYTES / 50 GB
GPU: 8 GB
NETWORK: PAPERSPACE

That’s my server ^

The only thing that I can think might be the issues is the curl http://files.fast.ai/setup/paperspace | bash script.

From the console:

Last login: Wed Jan  3 10:59:48 2018 from 10.64.0.1
(fastai) paperspace@ps23pk2x0:~$ jupyter notebook
[I 11:11:42.416 NotebookApp] Writing notebook server cookie secret to /run/user/1000/jupyter/notebook_cookie_secret
[I 11:11:43.021 NotebookApp] Serving notebooks from local directory: /home/paperspace
[I 11:11:43.022 NotebookApp] 0 active kernels
[I 11:11:43.022 NotebookApp] The Jupyter Notebook is running at:
[I 11:11:43.022 NotebookApp] http://localhost:8888/?token=token
[I 11:11:43.022 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[W 11:11:43.022 NotebookApp] No web browser found: could not locate runnable browser.
[C 11:11:43.023 NotebookApp] 
    
    Copy/paste this URL into your browser when you connect for the first time,
    to login with a token:
        http://localhost:8888/?token=token

(Ibrahim Khalil) #57

I have the same problem… No web browser found


(ecdrid) #58

@cedric
This might help…(the person is from nurture.ai Saturday chapter)


(Cedric Chee) #59

According to this:

For your case, I think if you can run Jupyter notebook server in Paperspace, things pretty much should just work. I have no idea what else might caused the issue, as I have not got a chance to try Paperspace myself due to billing issue.

Have you try following the guide created by reshamas?

I suspect you missed this “Step 2: open up firewall”
$ sudo ufw allow 8888:8898/tcp


(Ibrahim Khalil) #60

tried that as well… it still doesnt work for her… she then uses a ssh tunnel on her Mac… I have a restricted use Windows 7… dont know how to do that on this


(Radi) #61

It didn’t work for me. BTW I am on a Mac