Paperspace setup help


(Harsh Sikka) #538

2 Quick questions folks,

1 - should there be some sort of graphic display of the desktop through the paperspace web client like in the setup video?

2 - is the fast.ai image up to date? I only see ml1 and dl1 courses in there, shouldn’t there be a second one?


#539

Hi Amy-
I filed a complaint with the Better Business Bureau:
https://www.bbb.org/us/ny/brooklyn/profile/information-technology-services/paperspace-0121-170390
I also wrote to someone at fast.ai - sorry I can’t find the email. I’m not sure what did it - but I agreed to resolve the issue with the BBB if was refunded. Their billing practices are faulty. There needs to be handshake before the billing starts.
Good luck - don’t get discouraged.


#540

I am getting frustrated with attempts to work on remote machines. I believe I set up everything correctly this time per the instructions given here: https://github.com/reshamas/fastai_deeplearn_part1/blob/master/tools/paperspace.md
Then I loaded the Jupyter Notebook. I received some error message about expecting a string and receiving a number, or vice versa. I thought that was odd. The notebook loaded anyway. And it appeared to be working fine. Until I realized that there were only 5 executable cells.

I tried reloading the notebook multiple times. No error messages this time, but only 5 cells. I did a git pull for the second time. Still only five cells. I restarted the machine. Still only 5 cells.

So I went to lesson 2. And got the same error: " The error was:

[sprintf] expecting number but found string

See the error console for details."

Here is what the console displays:

Copy/paste this URL into your browser when you connect for the first time,
to login with a token:
    http://localhost:8888/?token=557215ff2d4e247928bea3764848a57b70de6b9e273c7b08

[W 17:25:45.617 NotebookApp] Forbidden
[W 17:25:45.617 NotebookApp] 403 GET /api/sessions?=1538688180184 (73.231.244.157) 2.00ms referer=http://184.105.191.13:8888/tree/courses/dl1
[W 17:25:45.618 NotebookApp] Forbidden
[W 17:25:45.619 NotebookApp] 403 GET /api/terminals?
=1538688180185 (73.231.244.157) 0.76ms referer=http://184.105.191.13:8888/tree/courses/dl1
[W 17:26:02.436 NotebookApp] Forbidden
[W 17:26:02.436 NotebookApp] 403 GET /api/sessions?=1538688180186 (73.231.244.157) 1.37ms referer=http://184.105.191.13:8888/tree/courses/dl1
[W 17:26:02.440 NotebookApp] Forbidden
[W 17:26:02.441 NotebookApp] 403 GET /api/terminals?
=1538688180187 (73.231.244.157) 0.65ms referer=http://184.105.191.13:8888/tree/courses/dl1
[I 17:26:02.457 NotebookApp] 302 GET /?token=557215ff2d4e247928bea3764848a57b70de6b9e273c7b08
(73.231.244.157) 0.38ms
[I 17:26:12.583 NotebookApp] Kernel started: a95b78b8-b002-4486-ad4b-88d355be1987
[I 17:26:13.108 NotebookApp] Adapting to protocol v5.1 for kernel a95b78b8-b002-4486-ad4b-88d355be1987
[W 17:32:24.569 NotebookApp] Notebook courses/dl1/lesson2-image_models.ipynb is not trusted
[I 17:32:25.068 NotebookApp] Kernel started: 191373b1-be4c-4901-8ac8-f9532592269e
[I 17:32:25.611 NotebookApp] Adapting to protocol v5.1 for kernel 191373b1-be4c-4901-8ac8-f9532592269e

Could someone please advise?

The only unusual occurrence I can think of is when I first tried to copy the IP Address, I clicked on it, so the console tried to load it from the same page, thereby creating an interruption. @dillon @jeremy


#542

I tried getting a new machine. I reinstalled everything. I waited to do conda env update. Before and after I got the same result. The only thing consistent is the IP Address from before. @dillon


(Todd Richard Johnson) #543

As a followup to help others, my Paperspace VM was shutting down due to the 1 hour timeout. If you SSH to the VM and start Jupyter Notebook, then access your Jupyter Notebook server from your local machine, Paperspace will not see your interaction. I bumped the timeout up to 8 hours and have not had trouble since.


#544

I set up fastai on paperspace yesterday, and I want to share a couple of gotchas in case anyone runs into the same problem:

  1. When select linux/ubuntu template, select version 16.04. i don’t believe fastai works with ubuntu v.18
  2. You may get an error about “sudo rm /etc/apt/apt.conf.d/.” when you use the command curl files.fast.ai/setup/paperspace | bash
    I ended up downloading the setup script from files.fast.ai/setup/paperspace (wget files.fast.ai/setup/paperspace) and comment out the line “sudo rm /etc/apt/apt.conf.d/.” before running it on the paperspace vm.