Paperspace setup help


#497

For me it is my bank card that is rejected on the site, while it works perfectly on other sites…
I think it may be that it is a french and not a US bank card.
i just submitted a ticket on their website.

Anyone else having a similar problem ?


#498

yeay, working !
I had a vpn : do not try to add a banking card when your vpn is active, they’ll reject it.

Everything else worked, with a notebook gradient.


(Ed Nonnenmacher) #499

I’d like to 3rd this. Have so far payed for the access to a machine that is hard to troubleshoot.


(Neil Kazimierz Sheridan) #500

oh dear! Mine did just say it was on after the provisioning completed… So I went ahead and clicked the shutdown button. So it seems it will bill if turned on even if no SSH connection? Makes sense I guess, since it could still be working. This was like my nightmare when I had the expensive $10/hr amazon EC2 machines running!


(Thomas Tracey) #501

I’ve experienced the same issues. Incredibly frustrating. I’ve wasted way too many hours trying to get Paperspace setup. I can’t believe Fast.ai recommends this service. Pure junk. Switching back to AWS.


(Thomas Tracey) #502

The same thing happened to me. I spent hours going back and forth with their support team. Paperspace refused to refund me but finally agreed to credit my account $400 towards future use. The problem is that Paperspace is unusable. I’ve wasted days trying to various approaches to configure my instance and get Jupyter Notebook running. I’ve scoured the help forums and followed instructions to the letter, but still fails. Now I’m just walking away, leaving the $400 in unused credits sitting in my account.

Over the past two years I’ve completed over 30 machine learning projects via AWS and FloydHub. Their tools and service are infinitely better. I only tried Paperspace because Fast.ai recommended it. What a mistake.

PAPERSPACE SUCKS. DO NOT USE IT…regardless of what Fast.ai says. You’re better off with AWS.


#503

I am planning to get started with this course so I wanted to check if this is the currently recommended approach rather then setting up a VM as described earlier.


(Daniel) #504

@2sk21 Definitely! For the most part, Gradient is easier to use than managing VMs. Let me know if you have any questions.


(Ravi Teja) #505

I Just typed every line from http://files.fast.ai/setup/paperspace into terminal.


(Chris Ivan) #506

Anyone else getting stonewalled by paperspace because their website refuses to update the fact that you’ve added a credit card? I get this ‘no valid billing method’ error that prevents me from moving forward with the course.


(Duncan) #507

Hey, @jeremy I set up paper space using the fast.ai template, like you said but when I tried opening the lesson1 jupyter notebook and some other jupyter notebooks it gave me an error. PLease Help

! It also says ‘500: Internal Server Error’ in big red letters.


(Spandan) #508

what is the updated promocode to setup a paperspace account ?


(Voltej) #509

You can use this one: 6J3HMRI


#510

They finally refunded my money.
I hope they change their billing practices to stop a machine that provisioned after a support ticket was filed, or require acknowledgement of a running machine from the customer before they start charging.
This was extremely stressful - but in the end they did the right thing.


(Chris Ivan) #511

Can someone please tell me if I’m right?
You can just use a gradient notebook for the course, and running the notebook is charged in the same way as running the VM, by the hour and for the storage space.
But, for some odd/stupid reason, whenever you stop the notebook to avoid paying for unused GPU/CPU/VM time, the notebook is permanently closed, and you have to clone it every time you want to resume the course???


#512

Here is another promocode that can be used:
U780WON


#513

I’ve set up a machine on Paperspace, using the fast.ai template and ran git pull and condo env update. However when I run jupyter notebook I get the following error:

[I 03:20:37.704 NotebookApp] 302 GET /?token=653f3040ba18d5d3d2f0b19787b4c58746f1c8717131348f (87.210.25.132) 0.84ms
[W 03:20:56.220 NotebookApp] Notebook courses/dl1/lesson1.ipynb is not trusted
[W 03:21:02.808 NotebookApp] 403 POST /api/sessions (87.210.25.132): '_xsrf' argument missing from POST
[W 03:21:02.808 NotebookApp] '_xsrf' argument missing from POST
[W 03:21:02.809 NotebookApp] 403 POST /api/sessions (87.210.25.132) 1.77ms referer=http://64.71.146.171:8888/notebooks/courses/dl1/lesson1.ipynb
[I 03:21:02.844 NotebookApp] 302 GET /notebooks/courses/dl1/images/sgdr.png (87.210.25.132) 0.89ms
[I 03:21:02.852 NotebookApp] 302 GET /notebooks/courses/dl1/images/pretrained.png (87.210.25.132) 0.81ms
[W 03:22:18.766 NotebookApp] 403 POST /api/contents/courses/dl1/lesson1.ipynb/trust (87.210.25.132): '_xsrf' argument missing from POST
[W 03:22:18.772 NotebookApp] 403 POST /api/contents/courses/dl1/lesson1.ipynb/trust (87.210.25.132) 7.75ms referer=http://64.71.146.171:8888/notebooks/courses/dl1/lesson1.ipynb
[W 03:22:22.486 NotebookApp] 403 POST /api/contents/courses/dl1/lesson1.ipynb/trust (87.210.25.132): '_xsrf' argument missing from POST
[W 03:22:22.487 NotebookApp] 403 POST /api/contents/courses/dl1/lesson1.ipynb/trust (87.210.25.132) 2.58ms referer=http://64.71.146.171:8888/notebooks/courses/dl1/lesson1.ipynb

Which manifests in the frontend like so:

NB In .jupyter/jupyter_notebook_config.py I changed the line

#c.NotebookApp.disable_check_xsrf = False

to:

#c.NotebookApp.disable_check_xsrf = True

to no avail.

Has anybody run into a similar problem and/or knows how to fix it?

Update: This seems to have been a browser issue (on Brave), on Chrome everything works fine.


(Srinivas Raman) #515

Yes - That is what I experienced as well and reason why I changed to requesting a Machine.


#516

After entering my billing info, trying to set up a machine, immediately have a problem - Cannot choose a GPU Machine, after choosing the Paperspace + Fast.A.I Container.

Am I missing something basic?


(Qixiang) #517

Another promotion code if you would like:
ZWQKA4D