Paperspace setup help

(Peter) #475

I understand that part, however how is spinning up an instance of a jupyter notebook worth it, if it’s not for heavy lifting? Might as well use my laptop_run_instance until the point I want to do the heavy computing stuff on the cloud_instance?

(Dien Hoa TRUONG) #476

You can choose the type of the VM machine when you open a notebook. With a K80 machine then I think it’s quite OK for doing deeplearning.

You can choose a cheap machine when doing the light computing (C2 is just 0.009$) then when you want to doing heavy computing, just stop this one and open a more powerful machine.

(Raghu Raj Rai) #477

I’m unable to access the fastai machine. I requested for access 20 days ago and wrote to them that I want to use it for this course.
Any advice?

(Xiwang Li) #478

Thank you for your reply. But How did you skip those lines?
Any modification to the code “curl | bash”?

Thank you.

(Aaron Lelevier) #479

I skipped the lines by running the working lines from that url ( web page. The url page is plain text run as a bash script.

(Pawel) #480

The best it would be to contact their support directly.


I am having the same error as well. If anyone has figured out a solution to this, please let me know!

The “ Public Template” was unavailable to me when I set up my machine, which is why I am having to do this installation now.

(Marjan) #483

I still have the same issue. Any solution to solve it?


I just started with paperspace now. I find for west coast region, there is currently no public ip available. for east coast region, i need request and wait for approval ( following reshama’s instructions )

And the FASTAI15 code has expired. The code in reshama’s post is still valid.

Hope it will get approved soon.

Is there any option to setup locally for this course? I have ubuntu 16.04 but don’t have GPU.


i have same problem with east coast option.


Hi, Thanks a lot! this seems a great option! I have tried create machine but need get approval.

For notebook, how is it charged?


(Nilabja Bhattacharya) #487

@dkobran can you please activate my account for terminal, my email id is Thank You

(Daniel) #488

You’re all set.

(Nilabja Bhattacharya) #489

Thank You So Much :slight_smile:

(Nilabja Bhattacharya) #490

When I apply, FASTAI15, it says promo code expired. Any other code for $15?

(Gene Chalfant) #491

Here, have a referral code: UWQMTGL


I didn’t expect the big headache with paperspace. I have chosen the paperspace per recommendation. Finally figured out that the current choice is to choose vm in east region ( west region run out of public ip ). And I have to request for linux or template. After two days, my linux 16.04 get approved.

I followed instructions (old one, since I am not using the template) to setup anaconda and jupyter notebook.

While I setup the jupyter notebook, I just couldn’t remotely access the notebook, authentication always fail. I have followed the instruction on jupyter notebook server setup literally. And I have previously setup a notebook on my own Ubuntu 16.04 without any issue, but the juytper notebook on paperspace just dont allow me to connect.

I have opened a ticket on paperspace .

i have spent hours on this. Does anyone have the same issue? So frustrated.


(Daniel) #494

@fzhcary Sorry for the trouble. We are recommending people use Gradient Notebooks to minimize some of the VM management issues.

Just select the container and choose a GPU type. That’s the entire setup process.


Back in January 2018 - I followed the directions to create and set up a machine. When setting my machine up all I got was a spinning wheel. After 20 mins of the spinning wheel I gave up and wrote them there was some thing wrong. There was an instruction in their support page to notify them if the machine didn’t provision within 10 minutes. They have no online support or phone to call. After writing to support to tell them the machine never provisioned I left the site and did not return.

A month later I find a charge for over $500! It never started and I had no clue that it was running - it started up after I left. Even though I wrote them to let them know the provisioning failed. - They refuse to refund this charge.

I am filing a complaint with the federal trade commission and encourage your users to work with a different company.

(kev) #496

/solved, got rid of “| bash”

Same!! anybody found a solution for this? Thanks