Paperspace setup help


I got my approval within 2 days. I guess you can wait or reapply again.

(Luis Enrique) #291

@keri how much is the cost for this instance, I say something about 7-9 dollars an hour is that right?
What type of machine did you chose?
Thank you for your help

(Keri Multerer) #292

So far, I have run a Linux p2.xlarge instance for 13 hours and have spent $11.89. I forgot to shut it down for a few hours, otherwise the use would be much less than that.

(Luis Enrique) #293

in AWS I looked for the “fastai-part1v2-p2 - ami-c6ac1cbc” instance since if I searched in the community AMI it would not be listed.
I installed the machine have access via ssh, however the files for the course were not copied.
Does anyone know what is the command to get all the files needed for the course copied to my machine that basically is blank?

(Keri Multerer) #294

From the instructions here:

Step 1: Choose an Amazon Machine Image (AMI)
Search Community AMIs [left menu]
Search: fastai

This worked for me to choose a fastai machine. Hope this helps.

(Luis Enrique) #295

Thank you for answering, I had not chosen the correct region where the AMI for was available.


@dillon Sorry for bugging you. I created a Paperspace account yesterday and just right now I created a new machine for the course. Since I am in Europe I picked the European data center and then I was asked to provide additional information regarding what I want to use the machine for. I just wrote that I want to use the machine for the course. However, now I just read your post, that you got inundated by a lot of non users and some other people here reported that they have already been waiting for several days to get approved. Thus, do I need to provide any additional information to proof that I want to use the machine for the course or do I just need to be patient and wait? Thanks!

(Saul Glasman) #297

Dear @dillon,

I’m also sorry to bug you, but I (saulglasman0 at gmail) submitted a request for access to the public template some time last week - could you possibly let me through?

(Harmanan Kohli) #298

why not use colaboratory, which provides free gpu in your google drive itself

(Jarbas Junior de Lira Carvalho) #299

Also waiting for approval…

(Luis Enrique) #300

I have reached to this point, i modified the config file, when I use the URL
I get an error unable to locate the local host
Please help me, it’s been too long and can’t get started
Everything else is complete

(William Horton) #301

that warning is fine, it shows up because it tries to auto-open the notebook, but your machine doesn’t have a browser installed. but the notebook is running on localhost:8888

(Roy) #302

I started the course last weekend and was able to create paperspace image without any issues.
I sent them an email for machine access and got approved in 30 minutes on a weekend.

I am definitely going to try to replicate it in GCP because of machine learning credits…

Also, read an article on Google Colab which is supposedly a viable alternative to Jupyter notebook.

(Luis Enrique) #303

I copy paste the http//lcoalhost:8888… into my browser and get the message of not able to connect to the URL

(William Horton) #304

So it’s running on localhost on your cloud machine, but to access it with your personal computer you need to substitute the public IP of your AWS instance for localhost. Or set up an ssh tunnel.

(Luis Enrique) #305

ok I will try that, thanks for your answer

(Jarbas Junior de Lira Carvalho) #306

My Jupyter server is running ok but when I try to access it on browser it’s not loading.
I put the public IP and the console shows a message when I requested the url on browser:

14:20:51.424 NotebookApp] 302 GET /?token=db4efd7ce7ce3d9be4ce3a5797630edd2f3a55f993145fb6 ( 0.61ms

But I can’t access the notebook.

Someone can help me?

(Luis Enrique) #307

Thank you, you were right!!
I needed to replace “localhost” with the public ip from AWS and also I had to configure the security group to allow the inbound connection, I set it to “all” all addresses all traffic

(Luis Enrique) #308

Check you have opened the right ports to get access to your remote machine, in AWS I configured the security groups to allow the inbound traffic, the easiest was to set to all, all traffic. I hope this helps.

(Jarbas Junior de Lira Carvalho) #309

Hi @leromerom, thank you for your help. I think the problem was because I was trying to access the remote server under my company’s firewall. I tried from my personal computer and it worked as expected. Thanks!