[minor] "No version information available" warning when importing modules

(Thom M) #1

Not really important because everything works, but when I run the first cell in the swift nbs, I always get this message a few times when it tries to import a library:

/home/jupyter/swift/usr/bin/swift-build: /home/jupyter/anaconda3/envs/swift/lib/libuuid.so.1: no version information available (required by /home/jupyter/swift/usr/lib/swift/linux/libFoundation.so)

/home/jupyter/swift/usr/bin/swiftc: /home/jupyter/anaconda3/envs/swift/lib/libuuid.so.1: no version information available (required by /home/jupyter/swift/usr/bin/swiftc)

Curious whether anyone else sees this & if there are any ideas to resolve; currently my plan of attack is to just keep ignoring it.

0 Likes

Jeremy's Harebrained install guide
(Jeremy Howard (Admin)) #2

Yup I get it and I think others have too. @marcrasi do you know how to avoid this?

0 Likes

(Pedro Cuenca) #3

I don’t have it, but I don’t use Anaconda, could that be the part of the reason? I’ll set up a conda environment and try.

0 Likes

(Thom M) #4

¯_(ツ)_/¯ Thanks! But I really wouldn’t waste any time on it if you’ve got other things to be doing :slight_smile:

0 Likes

(Darshan Kathiriya) #5

Hi, I had the same issue with libuuid.so.1 and i used this which solved my issue.

python register.py --sys-prefix --swift-toolchain ~/Applications/swift-tensorflow --swift-python-library ~/miniconda/envs/s4tf/lib/libpython3.6m.so

put your path to libpython3.6m.so

0 Likes