Lesson 1 Notebook - can't find dogscats data

Hi - please bear with a complete newbie! I have managed to get through various obstacles myself, but now I’m stuck. I wonder if I have unzipped the dogscats data into the wrong directory, but it looks to be exactly the same as in the video. It doesn’t help that I know very little of Linux. Anyhow, the notebook runs fine until the final step, when I get:

OSError: [Errno 2] No such file or directory: ‘data/dogscats/sample/train’.

Here is my Cygwin window:

Any help would be hugely appreciated.



1 Like

Can’t verify this atm myself, but I think when you run a notebook the paths are relative to where the notebook resides and not relative to from where you run the jupyter notebook server.

You seem to have data under ~/nbs, but your ipython notebook is under courses/deeplearning1/nbs? In such a case, the relative path to the data folder would be: ‘…/…/…/data’ or something like that. You might want to move your data folder to the courses/deeplearning1/nbs folder and this should solve this for you.

To check what your notebok considers its working directory, you can do this:
import os


Thanks - moving the folder worked!

1 Like

I can’t find the dogscats.zip file in the course GitHub. Where should I get it ?


I registered to kaggle and downloaded the two files. But, I could’t find sample zip file. Should we copy some images to the “sample” folder as we choose ?

1 Like

Look in http://files.fast.ai/data/


It would be really helpful if someone could add the new link was posted on the wiki’s lesson 1 and datasets pages. I’d do it myself, but it seems like you can’t edit the wiki as a MOOC student.

I am getting “Segmentation fault (core dumped)” error when downloading the dogscats.zip as follows, I have not found anyone asked this question. Can you please help? I am using aws p2.xlarge. Thank you !

Hi, did you get any answer to it? I’m having the exact same issue as well :frowning:

I replaced it with curl http://files.fast.ai/data/dogscats.zip -o dogscats.zip ;

I was also getting issues with unzip not being found, so I eventually fixed this latest one by doing:

sudo apt-get update
followed by
sudo apt install unzip

To get wget working, you can also call
sudo apt install wget

Thanks for the suggestion - I’ve done that now.

I think the problem occurs when wget is in too small a tmux pane to display its progress bar properly. Increasing the size of the tmux pane (e.g. by pressing ‘Ctrl-B’, then ‘z’) seems to fix it. Press the same keys again to return the pane to its original size.

1 Like

Seems you have worked it out, I have not. Thanks for sharing,

Hello all, I think I have a similar problem, but I can’t seem to get a data directory in nbs:


I think this is why I’m getting the “OSError: [Errno 20] Not a directory: ‘data/dogscats/sample/train’” error when trying to execute vgg16

Thanks for the help!

Yes, Thanks, your suggestion to move the dogscats folder into the data file (in the same directory level as the notebooks files) worked great for me!

1 Like