Howto: installation on Windows


#375

So now that PyTorch 1.0 is out with Windows and Cuda10 support, does anyone know the time frame for FastAI to support Windows?


(RAMJEE R) #376

@jeremy ,

Great lectures. I’m trying to work on lecture 10 for a NLP classification problem on a windows server that has 32 GB RAM and no NVIDIA GPU. Can you please let know if fast.ai can work on a server with no GPU. I know you have mentioned that NVidia GPU is a must but still asking. Thanks


(Laurence) #377

Worked for me! Thanks so much


(RAMJEE R) #378

Hi lollcat, Thanks. So, you were able to use fast.ai on a windows with no NVidia GPU ? Can you please confirm?


(Laurence) #379

Hi rramjee. No - I followed WakeMeAtThree’s post on installation with GPU that originally gave the error “PyTorch no longer supports this GPU because it is too old.” and have now successfully run lesson1.ipynb.


(RAMJEE R) #380

Oh ok sorry. Anyways thanks for your response. Good luck.


(Naveed Unjum) #381

I performed all the given steps but the it is pops up an import error on fastai.imports and fastai.structured but not fastai


#382

https://forums.fast.ai/t/pytorch-1-0-is-officially-released/32212/15

Should help.


(Naveed Unjum) #383

It says “you dont have access to this”


(Brian Smith) #384

Copying my steps here as the link was to the v3 course and is a locked forum.

This is the steps I’m using for my Conda environment. Windows 10.
conda create -n fastai-3.7 python=3.7
conda activate fastai-3.7
conda install pytorch torchvision -c pytorch
conda install -c fastai fastai
conda install nb_conda_kernels
python -m ipykernel install --user --name fastai-3.7 --display-name “Python (fastai-3.7)”
conda install ipywidgets

This works on my 1080ti - but I have seen the ‘too old’ message on other machines. GTX 480 and possibly Quadra mobile for example.


(Naveed Unjum) #385

It worked on my 1050Ti machine, Thanks. But fastai.structured is not being imported. This is the problem with kaggle too. Though i can simply copy the functions, i want to ask if there is a way that can be fixed


#386

Can’t clone the repository…on running the command “git clone https://www.github.com/fastai/fastai.git” I get an error namely:

fatal: unable to access ‘https://github.com/fastai/fastai.git/’: SSL certificate problem: self signed certificate in certificate chain

Specs:
CPU : Intel i7-7700HQ @2.8GHz
GPU : Nvidia 1050Ti (GP 107M) 4GB
RAM : 16GB


(SURESH SUBRAMANIAM) #387

Hi,

Setup fastai using instructions given by Jeremy. Excellent instructions and worked perfectly!

I set it up for ML using the commands below

cd courses\ml1
del fastai
mklink /d fastai …\old\fastai
cd …

I opened the courses\ml1\lesson1-rf.ipynb and imported the fastai libraries successfully.

Then I ran the following commands and set it up for DL

cd courses\dl1
del fastai
mklink /d fastai …\old\fastai
cd …

I opened courses\dl1\lesson1.ipynb. When I tried to import the fastai libraries it failed to find fastai.imports. When I tried to switch to courses\ml1\lesson1-rf.ipynb and tried to import the libraries, it failed too.

Can someone please explain what happened?

Thanks for your help!


(Naveed Unjum) #388

Refer to this


(SURESH SUBRAMANIAM) #389

Thanks naveed but I could not really understand. Perhaps if you mark the end of each line or format it better, it would more readable?


(Naveed Unjum) #390

Click the upward arrow button


(Vaibhav Kumar) #391

I followed these steps to setup my environment but a lot of libraries like seaborn,bcolz, graphviz were not present.
I individually installed them but graphviz still wasn’t getting imported!!


(Vaibhav Kumar) #392

Using the way specified by jeremy, I’m getting this error:


(Brian Smith) #393

Is your Conda up to date? I recall something like this a while back.


(Naveed Unjum) #394