Howto: installation on Windows


(Rodolfo Donã Hosp) #355

Did everything on this tutorial, but after i try to import fastai.imports i get the error “ModuleNotFoundError: No module named ‘dataclasses’”. Running on a Windows 10 64bit, NVIDIA GTX 1060 with 416 driver installed and did everything stated in the main post


(Kaspar Lund) #356

windows is not supported yet because pytorch 1.0 for windows has not been released.
Better use linux for now


(Stefan Bartelsen) #357

activate your environment and run

pip install dataclasses

that should resolve that issue.


(Paul Anderson) #358

Windows installation is a very long process. It depends on Windows OS version or device on which you want to install Windows. You can install Windows through CD ROM or Removable Pen Drive. If you going to install Windows on HP computer or laptop then you can get help from HP Support and they configure your system.


(Scott Riggs) #359

Can we refer to installing "fast"ai on windows as superslowai


(Shreyas) #360

Hello,

i followed steps mentioned above but we get following error when we try to run ml1/lesson1-rf.ipynb. uploading screenshot for your reference.

please let me know if i have missed something.


#361

I was unable to get the symlink to work because the “old” directory is not present when you get the latest pull. I point to fastai and it works fine…so far.


(Kamal) #362

https://docs.fast.ai/

from the docs, the installation method is this
conda install -c pytorch -c fastai fastai pytorch-nightly cuda92

but when I tried to do this, conda returned an error and says that it can’t find the channel, any help?


(Arijit Deb) #363

Hi,
I am trying to install the same following above instructions given in AWS windows(m4.xlarge) environment. I am getting below error.

Please let me know how to resolve the same.


(Graana) #364

Can we refer to installing "fast"ai on windows as superslowai. i try to import fastai.imports i get the error “ModuleNotFoundError: No module named ‘dataclasses’”.
Houses for Rent in Rawalpindi


(Vignesh Prabhu) #365

First time I executed all the steps pf installation, it ran smooth. I was able to run all commands on lesson1.ipynb

The next day I wanted to check lesson1 again, so I started anaconda prompt, changed directory ‘cd fastai’, ran ‘conda activate fastai’, ran ‘jupyter notebook’

As soon as I started executing the program error popped up No module named ‘fastai.imports’

So I again ran all the steps above, didn’t solve the issue.

What do i do?


(Kaspar Lund) #366

did you make a symbolic link archive in the directory of the course notebook to fastai ?


(Vignesh Prabhu) #367

Yes I did


#368

Hi, if anyone can help me to install fast,ai in my laptop highly appreciated. I keep having a error while installing and i ain’t got clue what package am i missing.


(Kaspar Lund) #369

support for windows will come when pytorch 1.0 has official support for it


(Saurabh Jadhav) #370

@Kaspar when executing mklink /d fastai …\old\fastai
I am getting warning “Cannot create a file when that file already exists.”
Can you please suggest what should I do to overcome it, I have followed all previous steps as per prof. Jeremy mentioned.


(Kaspar Lund) #371

that must be because there is already a folder/symlink called fastai. to replace it you have to delete it first


#372

It seems you make another env in this installation.(is this necessary? I installed fastai without making a new env with the tutorial of a CN fastai site(seems official))
I tried to make symlinks like step 8, but still can not import fastai.transform,
is this module stil exsit in version 1.0 ?


#373

I faced the exact same problem as you, but I found a fix! This is what I run on Anaconda Prompt so I don’t face any problems:

cd fastai
activate fastai
git reset HEAD --hard
cd courses\dl1
del fastai
mklink /d fastai …\old\fastai
cd … (no idea why the formatting is changing this to a ‘…’, just type what is given in the first post)


(Saurabh Jadhav) #374

Whenever I am running command “conda env update”
I get below error,
ChunkedEncodingError(ProtocolError(‘Connection broken: OSError("(10054, ‘WSAECONNRESET’)")’, OSError("(10054, ‘WSAECONNRESET’)")))

Did you face this error when updating env.