Howto: installation on Windows


(Gerardo Garcia) #333

If you don’t have admin rights on the PC

You can try two things.
Copy the folder fastai to the folder where the notebook page is located.
or
include on top of your notebooks at the very beginning before the fastai stuff

import os
import sys
sys.path.append(“PATH TO THE FASTAI FOLDER”)


(Mahyar Pedram) #334

I followed all steps from jeremys original post, however, when I run “lesson1.ipynb”, I receive the following error in line [3] from fastai.transforms import *

"AttributeError: module ‘torch’ has no attribute ‘float32’ "


(alparslan mimaroğlu) #335

same for me. If anyone can help please write your solution.


(Mahyar Pedram) #336

a reinstall of pytorch solved the problem for me:

(fastai)> conda uninstall pytorch
(fastai)> conda install pytorch -c pytorch


(Steve) #337

I received the following errors when running ‘conda env update’. Is this anything to worry about?

pexpect 4.6.0 requires ptyprocess>=0.5, which is not installed.

spacy 2.0.12 has requirement regex==2017.4.5, but you’ll have regex 2018.7.11 which is incompatible.


(Elijah Hoole) #338

Thanks Jeremy!

I managed to run lesson1.ipynb on my laptop with NVIDIA GeForce 840M GPU with Windows 10 following your instructions. But the PyTorch version which got installed conda env update did not support my GPU. I got this error message:
Found GPU0 GeForce 840M which is of cuda capability 5.0.
PyTorch no longer supports this GPU because it is too old.

After scavenging the forums, I followed the instructions listed on this thread:

Finally, everything worked. But when I monitored CPU and GPU performance on Task Manager while learning, the learner’s GPU utilisation was around 2.5-3 percent whereas the CPU utilisation was much higher around 50 percent (in certain stages).

I wonder if this is normal. Thanks. In any case, being able to do deep learning on my own laptop feels nice.