Getting started with Google Cloud

Hi all, I was getting shut down at every turn by Google Colab, whether it was incompatabilities or restrictions on GPU usage. I decided to try Google Cloud, and I need a little help with getting started.

I’m following the directions here.

Ubuntu refused to install on my computer in more ways than I could count, so I installed the Google CLI by going to Google’s support page and following the steps they recommended rather than following the fastai tutorial. Everything installed, and then I rejoined the tutorial.

With much frustration I made it 95% of the way through step 3 before I ran into a road-block. I ran the command in the tutorial:

gcloud compute ssh --zone=$ZONE jupyter@$INSTANCE_NAME -- -L 8080:localhost:8080

WNeill@DPKCNPW10PC1103 MINGW64 ~
$ gcloud compute ssh --zone=$ZONE jupyter@$INSTANCE_NAME -- -L 8080:localhost:8080
WARNING: The private SSH key file for gcloud does not exist.
WARNING: The public SSH key file for gcloud does not exist.
WARNING: The PuTTY PPK SSH key file for gcloud does not exist.
WARNING: You do not have an SSH key for gcloud.
WARNING: SSH keygen will be executed to generate a key.
This tool needs to create the directory [C:\Users\WNeill\.ssh] before
being able to generate SSH keys.

Do you want to continue (Y/n)?  y

Updating project ssh metadata...
....................................................................................................Updated [].
Waiting for SSH key to propagate.
The server's host key is not cached in the registry. You
have no guarantee that the server is the computer you
think it is.
The server's ssh-ed25519 key fingerprint is:
ssh-ed25519 255 5f:23:8a:4b:e4:0d:18:cb:86:16:76:02:43:eb:6f:b8
If you trust this host, enter "y" to add the key to
PuTTY's cache and carry on connecting.
If you want to carry on connecting just once, without
adding the key to the cache, enter "n".
If you do not trust this host, press Return to abandon the
Store key in cache? (y/n) y

At this point, I’ve been waiting for about an hour for this operation to complete. In the mean-time I noticed that a PuTTY terminal opened up with the prompt:


The tutorial said that this prompt would pop up in my terminal (Git Bash), but it never did. Instead this other terminal randomly opened, while bash seems to be hung up on trying to ‘store key in cache’.

Next I noticed that GCP has a GUI option to start a connection in about 5 different ways, but I’m afraid to do anything while I have two terminals up doing who knows what. I don’t think I’m connected to a GPU or being charged but I’m not sure.

While I wait, I decided to skip down to the step: In browser, go to localhost:8080/tree

This works to open up a jupyter page with the directory containing tutorials. I can navigate all the way to the lesson tutorials, but have no idea if the GPU is running or not. Each ‘epoch’ of the command fit_one_cycle is taking about 30 seconds, which is 3 times faster than using Google Colab with GPU… So is my GPU running? Can I close this hung terminal? Am I getting charged?

I’ve been trying to get through lesson 1 for 3 days, but all of these technical issues have me pulling my hair out.