Failed GitHub CI when following End-To-End Walkthrough

As per the title, GitHub actions fail when following the tutorial ( Error: Process completed with exit code 1.). has all (failed) runs, and I am unable to get it working.
Originally, not even the github page related actions were running, but I managed to fix that by starting from scratch and by focing the conda channel for nbdev in my conda environment.yml

Does anyone have any ideas? Ta!

Hey @ferranc,

Welcome to the forums and thanks for posting :smiley:

Within your CI fail run I can see on line 281 there’s a warning mentioning Detected unstripped out notebooks

On the following line there’s a reminder ‘Remember to run nbdev_install_hooks’. Run that and make a new commit to have some clean notebooks in your commit to re-trigger your CI.

Hopefully that will clean up your notebooks before you push and your CI will pass, pending hitting any other errors. Hope that helps! Let me know if you hit any other errors.


Funny thing, sometime back (I think last week) I was getting the same error even after manually cleaning before pushing. The CI was failing with the same error about cleaning.

If you look at his notebook files in the repo, they look stripped and cleaned off metadata so I am wondering what the issue could be.

In my case, I ended up just writing the code in a traditional IDE since I was behind my deadlines and had no time to investigate if the error I was getting was coming from my side, but seeing @ferranc having the same issue gets me wondering if it is a problem from the nbdev side of things. I will setup a basic repo tonight and see if that is the case.


gh ci proably has different (more up to date) version of nbdev. try updating nbdev locally.


Hi @miwojc , Can confirm it works now. It was probably a version issue as you mentioned. Thanks


yeah i was ‘debugging’ this for hours last time it happened to me lol


Thanks everyone! I could have sworn I tried nbdev_install_hooks, nbdev_clean and even experimented with pre-commit hooks yesterday while trying to troubleshoot it.
Following your comments I tried to update the nbdev package through conda (already had the latest version so nothing changed here), run nbdev_install_hooks once again (it seemed to not do anything), and run nbdev_clean too. The later changed 2 tracked files in the git repo, and upon pushing the changes the 2 CI actions on GitHub run without issue!

So thanks again for everything! I’m still unsure if it was just bad timing re. versions or if there is something that could be changed within the End-To-End Walkthrough (perhaps some kind of disclaimer/warning in case people encounter similar issues?)


So, turns out things are still not working 100%…

Now CI fails again during deploy. You can see the log here. Tried to troubleshoot the isssue by running export+test+clean+readme (instead of prepare) and found that it would fail at nbdev_readme with the message below:

Traceback (most recent call last):
  File "/Users/ferran/miniconda3/envs/VRland/bin/nbdev_filter", line 10, in <module>
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/fastcore/", line 119, in _f
    return tfunc(**merge(args, args_from_prog(func, xtra)))
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/nbdev/", line 46, in nbdev_filter
    with redirect_stdout(dn): filt(nb)
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/nbdev/", line 243, in __call__
    def __call__(self, nb): return self.nb_proc(nb).process()
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/nbdev/", line 126, in process
    for proc in self.procs: self._proc(proc)
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/nbdev/", line 120, in _proc
    if hasattr(proc,'end'): proc.end()
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/nbdev/", line 66, in end{'output-file': _nbpath2html(Path(self.nb.path_)).name})
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/fastcore/", line 247, in __getattr__
    def __getattr__(self,k): return self[k] if k in self else stop(AttributeError(k))
  File "/Users/ferran/miniconda3/envs/VRland/lib/python3.10/site-packages/fastcore/", line 216, in stop
    raise e
AttributeError: path_

Sorry to be a pain, but does anyone have any ideas as to what might be happening now (i.e. what is it I am doing wrong :sweat_smile:)

Just to add after some further tests: nbdev_readme still fails with the same error message when using different conda environments.
Consequently, the github CI deploy action fails at the same step when attempting to run this command (

These are the versions of the relevant(?) pacakges installed through conda:

  • fastcore fastai/noarch::fastcore-1.5.28-py_0
  • nbdev fastai/noarch::nbdev-2.3.12-py_0

hey @ferranc, I’m assuming you’ve installed nbdev and fastcore from conda. Can you install nbdev from pypi and try again?

To do so, run the following commands,

conda remove nbdev
conda remove fastcore
pip install nbdev

Hi all,

I am getting the same error as @ferranc mentions at the beginning of the thread. I am just following the tutorial step-by-step, installed everything using pip on Python 3.9.
I ran both nbde_install_hooks and nbdev_clean, but nothing changed so far.

Any ideas on what could have gone wrong?

1 Like

Ok, just answering my own question here.

After running pip install --upgrade fastcore pandas nbdev it seems to work fine

It’s strange though, because I installed nbdev like 30 minutes before that…

1 Like