CUDA not working on Windows 10

I’m starting new, specific thread for this problem so maybe we can pool our attempts and somebody finds the solution. It’s been discussed in Howto: installation on Windows multiple times without a proper solution.

So the issue is that after installing with Anacoda, everything supposedly works but for some reason Python/Jupyter fails to utilize CUDA for training and falls on CPU.

I’m running Windows 10 with CUDA 9 and latest NVIDIA drivers. Every torch.cuda test gives a result that everything should be fine but something fails somewhere. torch.cuda.set_device doesn’t fix the problem either.

This is quite hilarious but I’ve been fighting with this problem for few days and literally few minutes after writing the post above I had the idea of trying to run Anaconda Prompt in administrator mode and it actually worked!

Now GPU-Z shows me that GPU is utilized properly.

So, if you run into this problem, run Anaconda Prompt in administrator mode.

1 Like

There’s still something “fishy” with the setup. When I run lesson 1, I get about 3it/s with 1080ti and my CPU is at 100% all the time. GPU seems to do computing quite infrequently so either my i5-6600K is somehow completely overwhelmed by data feeding or something is not right.

Can anybody give comparison what kind of speeds I’m suppose to be seeing with something like 1080ti? I know the speed isn’t optimal due running desktop at the same time.

You are running the lesson 1 notebook, right? IIRC around 3it/s could be about right.

This is likely the culprit. Data augmentation is done on the CPU and from what you describe this seems to be the bottleneck.

I have a 1080ti and in general feeding it to 100% utilization is not that easy for most of the problems so I wouldn’t worry too much :slight_smile: If you are getting run times of the same order of magnitude as in the lecture I think you should be okay.

1 Like

@radek Thanks, that’s a relief :+1: Back to studying then, I rather spend time going through the lessons than dealing with the tech :roll_eyes:

1 Like

It is a parallel computing platform and application programming interface model created by Nvidia. It allows software developers and software engineers to use a CUDA-enabled graphics processing unit for general purpose processing. If it is not working on your Windows 10 that means you have to reinstall it. If in your Windows 10 Start Menu and Cortana Not Working and you cannot fix this then you should visit here Windows 10 Start Menu Critical Error to know how you can fix this error.

My anti-virus program indicates that the link is unsafe. (

Hope this isn’t a dumb question, but how do you run Anaconda Prompt in administrator mode? Did you mean running Powershell as Admin?

I’m having this same problem, my CPU is pegged at 100%, but I seem to be getting ~80it/s?

Locate the Anaconda Prompt file on your system and right click it. You should see Run as administrator as an option.

1 Like