Binder Deployment 404 Error

Hi everyone.

I made a apple/orange classifier based on Lesson 2 and I’m running into this issue when I try to deploy my app via Binder

I’ve tried everything I could find on the forum, with no success. The error occurs consistently on both Brave and Chrome (adblock turned off).
You can find the project here and this is what the binder prompts look like that lead to the 404:

Any help is much appreciated.

1 Like

Change the drop-down from file to URL (next to the launch button)


This worked, thank you!

1 Like

I’m having the same issue and one question I have is how do you know what to put in teh requirements.txt file?

I am having the same problem but even by changing to URL it doesn’t solve, any help?

There seems to be some more recent fixes on this HERE in the forums.(I’m working on the same issue).

Hello, I’m having the same 404 issue, though my code does not have any errors when I view it on GitHub or click the Voila button. I have ensured the requirments.txt file is there, as well as switched to URL and have the right path information.