Inconsistent versions of Voila, nbconvert and nbdev


Sorry if this issue was clarified in other topic but I’ve been stuck trying to turn my Notebook into a Real App for more than a week already, I haven’t been able to find a solution here or anywhere else on the internet.

My environment:

  • MacOS Catalina 10.15.7
  • Paperspaces-Gradient Free GPU-1 (M4000)

The history:

  • I saved a copy of all notebooks and other files in fastbook/clean to storage/mynotebooks
  • I’m working now in 02_prodcution. ipynb
  • I run all cells without problems until the last one; the Voila installation.

The command:

!pip install voila --use-feature=2020-resolver
!jupyter serverextension enable voila --sys-prefix

The result:

ERROR: nbdev 1.1.5 requires nbconvert<6, but you’ll have nbconvert 6.0.7 which is incompatible.
Successfully installed nbconvert-6.0.7
Enabling: voila

  • Writing config: /opt/conda/envs/fastai/etc/jupyter
    • Validating…
      voila 0.2.4 OK

The problem

Despite the error message, I have Voila installed (there is a Voila icon in the top menu), but when I try to run the notebook in Voila, I receive an error message:

ERROR: Voila 0.2.4 requires nbconvert<7, >=6, but you have nbconvert 6.0.7 which is incompatible.

Therefore, I’m in a situation where Voila requires nbconvert >=6 while at the same time nbdev requires the same nbconvert to be <6.

I hope any of you can help me to identify what I’m doing wrong, and more importantly, how to fix it!

Many thanks in advance.

Ok, after 4 days without any response to my problem, I guess there is not an easy answer to my question.
Then, could any of the experts or moderators at least indicate which other sources could I consult in search for an answer, (other than fastai, voila and nbdev or nbconvert or stackoverrflow)?

Many thanks,