Windows Installation | SSH Error


(byron.allen) #1

I’ve been able to setup my P2 server, but can’t connect to it. I think I need to install SSH. Is there a simple way to do that without having to reinstall cygwin?

Here’s

Natasha@DESKTOP-3EL2MN8 ~
$ bash setup_p2.sh
rtbassoc-06d92860
True
Waiting for instance start…

Connect: ssh -i /home/Natasha/.ssh/aws-key.pem ubuntu@ec2-35-160-223-42.us-west-2.compute.amazonaws.com

Natasha@DESKTOP-3EL2MN8 ~
$ ssh -i /home/Natasha/.ssh/aws-key.pem ubuntu@ec2-35-160-223-42.us-west-2.compute.amazonaws.com
-bash: ssh: command not found

Thanks,
Byron


(Jeremy Howard (Admin)) #2

Sure. There’s two ways to add stuff to cygwin:

  • Run cygwin’s setup again, and select the additional package you want. This doesn’t actually reinstall cygwin, but just adds the package(s) you select
  • Install apt-cyg, then ‘apt-cyg install openssh’

(Josh Zastrow) #3

Hi there, thanks for the advice, had the same error as Byron… though it doesn’t look like apt-cyg installed openssh for me…

joshu@LAPTOP-C6H0BQOF ~
$ wget rawgit.com/transcode-open/apt-cyg/master/apt-cyg
--2017-01-11 18:23:21--  http://rawgit.com/transcode-open/apt-cyg/master/apt-cyg
Resolving rawgit.com (rawgit.com)... 104.18.63.176, 104.18.62.176
Connecting to rawgit.com (rawgit.com)|104.18.63.176|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://raw.githubusercontent.com/transcode-open/apt-cyg/master/apt-cyg [following]
--2017-01-11 18:23:22--  https://raw.githubusercontent.com/transcode-open/apt-cyg/master/apt-cyg
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.100.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.100.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13765 (13K) [text/plain]
Saving to: ‘apt-cyg.4’

apt-cyg.4                   100%[========================================>]  13.44K  --.-KB/s    in 0.04s

2017-01-11 18:23:22 (357 KB/s) - ‘apt-cyg.4’ saved [13765/13765]


joshu@LAPTOP-C6H0BQOF ~
$ install apt-cyg /bin

joshu@LAPTOP-C6H0BQOF ~
$ where apt-cyg
C:\cygwin64\home\joshu\apt-cyg
C:\cygwin64\bin\apt-cyg

joshu@LAPTOP-C6H0BQOF ~
$ which apt-cyg
/usr/bin/apt-cyg

joshu@LAPTOP-C6H0BQOF ~
$ apt-cyg install openssh

joshu@LAPTOP-C6H0BQOF ~
$ ssh -i /home/joshu/.ssh/aws-key-fast-ai.pem ubuntu@ec2-35-167-169-191.us-west-2.compute.amazonaws.com
bash: ssh: command not found

(Josh Zastrow) #4

Figured it out:

Had to go back to the cygwin setup, search for lynx and install that. Then I used lynx to install apt-cyg per the github link Jeremy posted. Once that was done, then the commands to install openSSH worked for me

Side note: For some reason wget wasn’t getting installed when I selected it on the Cygwin setup program. I used lynx on the command line (added C:/cygwin64/bin/ to my path variable) to install wget.


(Jems Ford) #5

Windows is the most popular operating system because it uses most of the people in the world. You can simply install the Windows.When an SSH session closes with either Write failed broken pipe or Network error : Connection reset by peer," it means the session has timed out when you install the Linux. If your windows are not working properly then you can If your windows are not working properly then you can contact 0x800705b4 for the best solution.


(Ben Cuttings) #6

If you are getting some error code on your Windows then it means you have not installed Windows properly you can reinstall it again. If you are using a Dell laptop and it is not starting or it won’t turn on then you may visit this Dell Laptop Won’t Turn On to fix this problem.


(pragatiG) #7

For any system errors and network issues you can contact FieldEngineer.com a global marketplace where you get a solution easily.


(john) #8

This had to be the most valuable piece of information I received from this article: " Even though points modify each of the time, consider adding an updated url to old articles or blog posts. If website visitors discover previous posts initially with outdated information and facts, they are able to find the existing version effortlessly as a result of your applied website link."

When I put in articles and some of my posts end up getting older, they may still be relevant to the current market. In addition to that, if the information may need some new content, which I put in a new post, then I am able to do so by adding a link to the newer content. I appreciate that tip. Thanks.
Here in Atlanta, we appreciate it:
office.com/setup
office.com/setup