Why can't I use anaconda?

On the lesson 1, i’ve followed everything until 1:05:05. There were some problems, but i’ve solved all of those… by Googling and doing some pip sudo stuffs.

Now as i’ve typed in ‘which python’, I expected home/ubuntu/anaconda2/bin/python.
However it retrieves /usr/bin/python.

Also, ‘jupyter notebook’ wouldn’t work. It says jupyter command not found. It only works when I type in ‘ipython notebook’.

So, this means that I’m not using anaconda right? What is the problem? How could I fix it and use anaconda? I’m very confused. Would appreciate your help.

run echo $PATH to see what is in your path. That is how command line finds which python to use. One thing that you may want to try is to go and open a new terminal. Under some cases the old PATH is present which will cause wrong python to be picked up

Aseem, thanks! I ran echo $PATH and this is what it shows


Just started new terminal, and this is what I could find

ubuntu@ip-10-0-0-12:~$ jupyter notebook
jupyter: command not found

ubuntu@ip-10-0-0-12:~$ ls
anaconda2 downloads git nbs

ubuntu@ip-10-0-0-12:~$ which python

Hmm I think now problem is solved. But not sure what’s going on.

I was googling around, and was recommended to type in ‘bash’(in Ubuntu) and then try again.

bash made my command line bit thicker.

And now as I type in ‘which python’, it gives me /home/ubuntu/anaconda2/bin/python

whole conda thing won’t work after i exit from bash.

What exactly is bash, and what’s happening in here? Should I type in ‘bash’ every time I work in Ubuntu?

To get a better understanding of Anaconda, you should read about Anaconda environments.

Bash is a Unix shell, the most popular one in fact. A Unix shell is a command line environment in which you can call commands and create scripts. You could use any shell with anaconda.

1 Like

Thanks! Since it had too much troubles as I move on, I’ve deleted every Anaconda3 installed, and started everything over again with the Anaconda2. Now everything works just fine. Perfect. Thanks for helping me!