Warning: Think twice before trying to dual boot Linux on a Windows machine

I’m just venting here, but I’ve spent the last 5 hours trying to get my machine back after bricking it from trying to install Linux. And that’s after wasting another 6-8 hours yesterday getting the GPU to work on my windows machine only to find out it can’t get past the training in the cats vs dogs problem.

I followed the instructions for Windows 10 and got Lesson 1 up to the point where it started to train and ended up crashing in the middle.

And I googled the error message I got and it advises installing Linux

So I figured it shouldn’t be too bad since I’ve been installing Linux for dual booting on many machine for over a decade… little did I know that since the new machine I’m using right now uses UFEI, I’m in for a world of pain…

I burned Linux Mint onto a USB stick and my machine won’t boot it. I googled why and it seemed I needed to disable UFEI. So I did. And the installer loaded. Then it was time to partition my drive and I set aside some free space for a linux partition. And proceeded to install Linux.

Then when I rebooted, I was greeted with Linux. Great. But I still want to use Windows for everything besides Fast.ai. And I never got that Grub or whatever window upon rebooting my machine.

Here’s what I’ve tried so far to restore my Windows partition:

  • Booting into Linux and running ‘sudo update-grub’: it doesn’t detect my windows partition.

  • Running ‘sudo os-prober’ : still doesn’t find my windows partition

  • Creating a Windows 10 boot disk on a USB drive. I’ve wasted the past 3 hours doing this. Since I couldn’t boot from windows, I had to download and burn the USB boot disk from Linux and every time, it takes like 30 minutes. First burn was a failure. 2nd time was also a failure. Upon booting, my machine completely skipped the USB drive. I tried turning UFEI back on again and my machine refused to boot at all. At least with UFEI turned off it boots into Linux.

Yesterday, I wasted like 6-8 hours trying to get fast.ai working with GPU support on my Windows 10 machine (granted, several months ago, I had gotten Tensorflow to work fine with GPU support with ZERO hassles but for some reason fast.ai didn’t like my CUDA installation and I had to upgrade everything to CUDA 9 and TF 1.5 in all of my Anaconda environments.) And today just as I thought I could finally be doing some exercises, my machine is now unable to boot back into Windows and another day is wasted repairing it (and still no end is in sight.)

I should have gone with the cloud option from the start… sigh

Yeah, you should have. If I were you I would have gone to the local cyber cafe to download and create a bootable usb drive. And wiped the whole hard drive and would have removed uefi.

dual boot appears obsolete to me now. VMs instead.
I feel for your pain, we’ve all been there
edit: jeremy confirmed CUDA doesnt work though virtualization. I should have emphasized I’ve no background in DL

Update: As of right now, my computer is completely bricked after trying to install Linux. Here’s everything I’ve tried so far:

  • Creating and booting with the Windows 10 recovery media: I’ve burned MULTIPLE Windows 10 recovery disks on multiple USBs and every single one of them gives an error upon booting (usually something like the drive is corrupted.)

  • Burning the “Boot Repair Disk” to USB: the USB boots but hangs halfway through splash screen

  • Booting with the Linux Mint USB again: same as above, hangs halfway through splash screen (even though it didn’t do so when I was first trying to install my system.)

  • Downloading the burning the Dell Recovery and Repair tool and installing it to a USB drive: even though this was designed to restore my computer to its factory defaults, it fails to do so, reporting a problem with my computer’s boot record or something.

My computer will only boot into Linux at this point and even then, it’s still dysfunctional (since my touchpad doesn’t work, I have to attach an external mouse to do anything to control the computer so it’s not a solution.)

dual boot appears obsolete to me now. VMs instead.
I feel for your pain, we’ve all been there

Correct me if I’m wrong but I thought you can’t install CUDA in a VM?

Yeah, you should have. If I were you I would have gone to the local cyber cafe to download and create a bootable usb drive. And wiped the whole hard drive and would have removed uefi.

Yeah, I would do something like that if USB drives would boot. Right now, none of the 3 or 4 recovery USBs I’ve burned work.

Hey, while creating the drives have you taken into account the uefi mode? If not you can use rufus to create UEFI bootable drives using this guide (make sure to use rufus):

Then you can create UEFI bootable linux drives using this:
https://www.vanstechelman.eu/content/creating-an-uefi-bootable-linux-usb-stick

Note: Use rufus and windows to create both drives, go to a cafe if you do not have access to either. Check your bios settings and rearrange the boot order so that it uses the usb to boot. (see this)

See if it helps. Good Luck.

Yes, I’m already using Rufus, and yes, I’ve tried both GPT and MBR UEFI modes to no avail.

I’ve tried maybe 4 or 5 different USB drives, formatted on 2 different computers, all resulting in the same lock up in the middle of booting (they all boot successfully but don’t complete booting.)

Only thing I haven’t tried yet is burning in DD mode instead of the default ISO mode which I’m trying next.

And the boot order? Have you disabled secure boot in BIOS?

Yep, boot order has USB at the beginning and secure boot has always been disabled… haven’t tested enabling it yet.

Damn, I am out of ideas. Tried calling customer care?

Tried that at 2am last night after hours of trying everything above… they’re charging $160 for the warranty in order to send in and service my laptop. They did tell me to try downloading and installing the Dell Recovery and Repair boot USB which restores everything to factory defaults and surprisingly, that thing boots on my computer, unlike all other other USB boot disks I’ve tried. Unfortunately, that thing throws an error when checking the boot files and is unable to restore the boot files, hence not being able to restore my boot record.

Ok, as a final resort try formatting the whole hard drive, change the boot partition record and reinstall OS. This will wipe EVERYTHING. And do google up some guides on how to do this.

Edit: Specifically change from GPT(UEFI) to MBR(Traditional)

any chance to have 2 hard drives? it will save lots of headaches having the OS’s separate.

Yeah, this would be ideal. But I have been dual booting since years without problems once I changed from GPT to MBR.

SUCCESS!

I burned another Windows 10 USB recovery disk, this time using my work PC, and it booted and installed Windows 10 fine on my laptop. I guess I’ll heed your advice and go with virtualization instead of dual boot now that I’ve learned my lesson, and if that doesn’t work, there’s always Crestle.

1 Like

Awesome. Happy Learning :slight_smile:

CUDA doesn’t work with virtualization.

1 Like

There is always a risk due to hardware differences (and manufacturers don’t usually test for Linux). To be really safe, you should use disk imaging tools (like AOMEI Backupper) to backup and restore a working installation (on a second hard disk, ideally).

Try to install Ubuntu 16.04 next time, it should work well with most UEFI systems, but there are some systems that are set up to use some kind of legacy/hybrid implementation, which may be challenging for normal users to figure out the correct way to proceed. In your case however, I suspect that your Linux was not installed during UEFI boot to begin with. UEFI is not something you can disable after your Windows has been installed (since it expects a UEFI partitioning scheme), but you did it anyway and managed to complete the Linux installation under BIOS mode (since UEFI is off), so botching Windows (in a minor way) is not surprising.

I burned Linux Mint onto a USB stick and my machine won’t boot it. I googled why and it seemed I needed to disable UFEI. So I did. And the installer loaded. Then it was time to partition my drive and I set aside some free space for a linux partition. And proceeded to install Linux.

This is probably the key mistake. You needed a Linux Mint installer that can boot in UEFI mode (since you have an existing UEFI system with Windows 10 installed).

Running a dual boot setup myself and can feel your pain. After a similar experience to yours what I decided to do was just not let windows know about my linux installation. To that end, when I installed Linux Mint (like Ubuntu, but waaaay nicer), when I set up my partitions, linux went on a separate disk, with one swap partition and one root partition, which is where the boot loader went as well. My machine still boots into windows by default, but during the boot screen I can hit F11 and choose the ubuntu option instead, which takes me to Grub, where I actually boot linux. Not perfectly seamless, but it works and I didn’t have to muck with anything in the UEFI settings. Hope this helps and good luck.

I was also worried about Windows and Ubuntu fighting it out on one HDD on my PC, so I installed another HDD for Ubuntu and have had a similar experience to antinihilist. Again, not seamless but it does work and I can switch back to windows easily should the need arise. The extra HDD needn’t be very big. I have found over the last year or so that most of what I need for my development work i.e. ML, DL, Python etc is easier to install and faster under Linux than windows.