VGG16 model not found


I am trying to get the first 7 lines of code working from the first python notebook of lesson 1 where you import VGG16 and try to train with it. I have tried to get it running on a Windows machine, an Ubuntu machine and on a DigitalOcean droplet and they all give me the same error: AttributeError: ‘Model’ object has no attribute ‘getbatches’. It looks like my VGG16 is not importing correctly or something.
Does anyone have any idea on how to fix this, and why do i get this error on 3 of my machines?


Kind regards,

Gertjan Brouwer

Hi Gertjan,

If that is an exact copy it should be ‘get_batches’ and not ‘getbatches’ as that’s how it’s named in the vgg16 class. Maybe something got misspelled in your notebook somehow? If that’s just a typo have you looked through your vgg16 class and seen if get_batches looks alright? Perhaps you could try retrieving everything from git again if your source somehow got corrupted.

Im so sorry that is my mistake, I did not copy the error correctly from my other machine, i use get_batches. And i looked into VGG16 and it does not have that function in it, i only see how the model is build with all the layers and thats it

Sounds like you have an incorrect source for your model files then. Try downloading them anew from and see if that helps. If not please post your entire workfolder on for example git or it’s hard for us to say anything more :slight_smile: