UnsatisfiableError on AWS EC2 instance

Hi All

I have been able to launch and get running an AWS p2.xlarge instance successfully however I am getting an error when running this command.

conda install -c pytorch -c fastai fastai pytorch torchvision cuda92


WARNING conda.base.context:use_only_tar_bz2(632): Conda is constrained to only using the old .tar.bz2 file format because you have conda-build installed, and it is <3.18.3. Update or remove conda-build to get smaller downloads and faster extractions.
Collecting package metadata (repodata.json): done
Solving environment: failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

  • pkgs/main/linux-64::krb5==1.14.2=hcdc1b81_6
  • pkgs/main/linux-64::pykerberos==1.2.1=py36h14c3975_0 -> krb5[version=’>=1.14.2,<1.15.0a0’]

Error End----------

Has anyone experienced something similar. Any ideas what I should try to work around this.

Many thanks

Hi, I faced the same problem and removing pykerberos solved this for me.

First, conda remove pykerberos
Then, conda install -c pytorch -c fastai fastai pytorch torchvision cuda92


Thanks @rishsriv that solved my problem too…

you can use some tools like floydhub or clouderizer.com. They give a great out of box connect with gcp and aws with eliminating almost all devops challenges.