Unreadable Notebook: /home/ubuntu/nbs/lesson1.ipynb NotJSONError("Notebook does not appear to be JSON:


I understand that http://www.platform.ai/files/nbs/lesson1.ipynb does not exist anymore.

I then refer to the Github shown in the course :

I have done the below :
wget https://github.com/fastai/courses/blob/master/deeplearning1/nbs/lesson1.ipynb
curl -L -o lesson1.ipynb https://github.com/fastai/courses/blob/master/deeplearning1/nbs/lesson1.ipynb

The issue is when I evoke the ipynb from jupyter notebook (nbs then lessons1.ipynb) then error :slight_smile:"Unreadable Notebook: /home/ubuntu/nbs/lesson1.ipynb NotJSONError(“Notebook does not appear to be JSON: :::”

I have checked the content of the file lesson1.ipynb, it’s been tranformed into HTML format file.
It seems that there’s no tool to convert from HTML into ipynb (the other way round exists and works fine) ?

I know I can download the whole zip ‘courses-master.zip’ onto my disk. Yes I have Anaconda installed on my laptop.
But I understand we are using the GPU serveur (P2) from AWS so I think I should download (wget) everthing onto my P2 machine (on the AWS) and run everything from there ?

Is it possible to make http://www.platform.ai/files/ available again ?

tks n rgds,

I just saw from one of the discussions :slight_smile:
"Please note: use files.fast.ai, not platform.ai, from now on "

So thank you for that : I ll try that out.

best regards,

I’m having this same issue. Jade, were you able to resolve this?

I went to “http://files.fast.ai/files/nbs” and saw the note “This is not the place to download notebooks or spreadsheets from any more. Please use git, as mentioned in How To Get Started.”

I found the file on Git (https://github.com/fastai/courses/tree/master/deeplearning1/nbs), and did wget from Git to my AWS instance, downloaded the lesson1.ipynb and tried to open it in Jupyter.

Error: Unreadable Notebook: /home/ubuntu/nbs/lesson1.ipynb NotJSONError(“Notebook does not appear to be JSON: u’\n\n\n\n\n\n\n<html lan…”,)

I also can’t find the file “couses-master.zip,” which may have the un-converted notebook?

Is there a location for working lesson notebooks?


In case anyone has this same problem, I figured it out. The actual “raw” Python notebooks are stored in a different place on Github. You can access it by first clicking on the notebook (which will open it in your browser), then right-clicking “Raw”, and selecting Copy Link Address. Here it is for lesson 1:


The only difference in the address is that the “tree” folder is switched to “raw.”



Hello Max,
Thanks for your informations. Yes, same to me “http://files.fast.ai/files/nbs” is not available, either.

For some reason I don’t understand :smile:
==>This time, it lets me choose from my local disk (not on the AWS server) the ipynb files (notebook files),

As it 's from my PC, and the ipynb files were downloaded (a zip fie) from the Github (by clicking from the url shown on “Please use git, as mentioned in How To Get Started”. It is working fine when I evoke it locally from my Jupyter Notebook (I had Anaconda installed as part of pre-requisite).

==>Therefore, since it lets me choose lesson1.ipynb from my local disk, it’s OK now.

The only thing I still don’t understand is -
Before, when I had issue on opening the file after doing “wget and the url of github/lesson1.ipynb” then got systematically the error "Unreadable Notebook: /home/ubuntu/nbs/lesson1.ipynb NotJSONError("Notebook does not appear to be JSON: u’\n\n\n\n\n\n\n<html lan…"
It was because I chose the file from AWS serveur done by the wget. It seemed quite logic to me since I have launched jupyter notebook on AWS’s instance /home/ubuntu/nbs/lesson1.ipynb

Now, I do the same thing : i.e. I launch jupyter notebook on AWS’s instance -

ssh -i /Users/uuu/.ssh/aws-key-fast-ai.pem ubuntu@ec2-5x-3x-3x-7.us-west-2.compute.amazonaws.com
jupyter notebook

Then on a new chrome Tab 'ec2-5x-3x-3x-7.us-west-2.compute.amazonaws.com:8888
password : dl_course

==> when I try to upload a notebook, it lets me choose from my local disk the ipynb files. No longer from ubuntu.

Do you have hints on why it happens like that ?
will there any impact on the following exercises if I choose ipynb files from local disk (and not from AWS?

tks n rgds,

Thanks a lot Max! You post saved a lot of time!

Yes, Max’s solution works :get lesson1 notebook from the below link to overcome issue with error "Unreadable Notebook: /home/ubuntu/nbs/lesson1.ipynb NotJSONError(“Notebook does not appear to be JSON: u’\n\n\n\n\n\n\n<html lan…” when evoke the lesson1.ipynb from Jupyter Notebook.

good link :

In order to recuperate the data, I actually installed Kaggle on the AWS server-instance:
Create profile at https://www.kaggle.com/
On server: pip install kaggle-cli
kg config -g -u [username] -p [password] -c dogs-vs-cats-redux-kernels-edition
mkdir ~/nbs/data/dogscats and cd to it
Go to https://www.kaggle.com/c/dogs-vs-cats-redux-kernels-edition and accept competition requirements (by downloading the data)
On server: kg download

For data, you ll need to install unzip tool if it does not come along with the AMIS :
$ sudo apt-get install unzip

When the downloaded data are on the AWS server-instance, we can check the number of files:
ubuntu@ip-10-0-0-6:~/nbs/data/dogscats$ ls test | wc -l
ubuntu@ip-10-0-0-6:~/nbs/data/dogscats$ ls train | wc -l

tks n rgds,


I forgot to say I actually used kg download to get the ipynb files as well.

Thank you so much for this Jade and Max. One question: when I click on lesson1.ipynb in my Jupyter notebook, I get the raw JSON version of the notebook, and not a nice looking Markdown file like the one depicted in the video. Does anybody know how to resolve this?

EDIT: Resolved the problem. Simply rename the notebook so it ends in the .ipynb extension. My notebook was actually a duplicate so it was named “lesson1.1.ipynb” so it was being interpreted in raw JSON.


Hi everyone, having the same problem with the unreadable notebook. I tried the new file with the link Max posted and tried wget with that address and it worked.

My issue is that the file was working before and all of a sudden it stopped working. Anyone else had the same problem?

Thank you, Jade this was helpful.