Unable to resolve platform.ai while connected to the internet on Ubuntu 16.04

I’m not sure if this really belongs here, but I can’t find anything else online.

When trying to download cuDNN I get the following error

$ wget "http://platform.ai/files/cudnn.tgz" -O "cudnn.tgz"                                                                                                                                                                                                                               
--2017-05-03 21:19:22--  http://platform.ai/files/cudnn.tgz
Resolving platform.ai (platform.ai)... failed: Name or service not known.
wget: unable to resolve host address ‘platform.ai’

Now I am most definitely connected to the internet, and I also think my DNS is working properly, since I’m writing this on the same machine I tired to download the file. It also doesn’t work if I try to download via a browser, saying it can’t resolve the name.

I also tried dig -t A platform.ai +short but not getting any response (works for other domains).

Edit: as a side question, why are the .tgz and .sh installers recommended instead of the nvidia provided .deb packages?

1 Like

platform.ai has been replaced by files.fast.ai . Let me know anywhere you see platform.ai, and I’ll try to fix it!

Cool :slight_smile: I found it here https://github.com/fastai/courses/blob/master/setup/install-gpu.sh#L49

The link to dogscats.zip at the location below also has platform.ai.


I created this PR to update all occurrences of www.platform.ai to be files.fast.ai.


Thanks Allen, works well.

In the youtube videos, at least in the lesson one video: https://youtu.be/Th_ckFbc6bI?t=49m27s. The platform.ai web address appeared in both the browser and your command line demo. An on-screen callout would be greatly helpful for first time course taker.



@jeremy Could you set a CNAME entry on platform.ai to be an alias of files.fast.ai? This way, the old domain will still be supported and does not break exisiting documentation, while you won’t need to care about further DNS settings anymore.

Unfortunately not, since I’m helping create a company that will be using this name and domain!

Thanks so much! :slight_smile:

Maybe a 301 Moved Permanently redirect for people / search engines to be able to adjust links when stumbling upon old documentation? Broken links are so frustrating… :wink:

I just happened to recently start with lesson 1, where you are downloading the files from http://platform.ai/files, as xlaokunxu mentioned. I wrote a little script which did the download for me. A couple days later, when I tried to execute it on a GPU enabled machine, I panicked a bit when the download failed, not being sure what was happening to your project.

By the way: the old dogscats.zip from http://platform.ai was 857,2 MB in size, http://files.fast.ai/data/dogscats.zip is 818 MB, http://files.fast.ai/files/dogscats.zip is 822 MB. I’m currently downloading all of them to compare them, not sure if all those data sets work for the lesson.

Anyway, thanks for all the effort you put in here, and good luck with the new company! I’ll also report it here when I find platform.ai links in your lessons.

I’ll see if I can get something set up.

Odd… Please do let me know what you find.

Within vgg16.py, there is a reference for: http://www.platform.ai/models/

Here is the error message from lesson1 notebook:
vgg = Vgg16()

Grab a few images at a time for training and validation.

NB: They must be in subdirectories named based on their category

batches = vgg.get_batches(path+‘train’, batch_size=batch_size)
val_batches = vgg.get_batches(path+‘valid’, batch_size=batch_size*2)
vgg.fit(batches, val_batches, nb_epoch=1)
Downloading data from http://www.platform.ai/models/vgg16.h5

Exception Traceback (most recent call last)
in ()
----> 1 vgg = Vgg16()
2 # Grab a few images at a time for training and validation.
3 # NB: They must be in subdirectories named based on their category
4 batches = vgg.get_batches(path+‘train’, batch_size=batch_size)
5 val_batches = vgg.get_batches(path+‘valid’, batch_size=batch_size*2)

/home/ubuntu/hw1/vgg16.py in init(self)
30 def init(self):
31 self.FILE_PATH = ‘http://www.platform.ai/models/
—> 32 self.create()
33 self.get_classes()

Already fixed - please git pull

http://platform.ai/data/dogscats.zip and http://files.fast.ai/data/dogscats.zip are actually the same, I just mixed up Megabyte and Mibibyte. http://files.fast.ai/files/dogscats.zip contains a couple more pictures in the “sample/” directory, but the structure is otherwise the same.

Thanks! If it is any help to you, a simple nginx configuration might look like this:

server {
    # ...
    location ~ ^/(files|data|models) {
        return 301    http://files.fast.ai$request_uri;
1 Like

Can you please edit the link in Py3 and tensorflow setup?

wget http://platform.ai/files/cudnn-8.0-linux-x64-v5.1.tgz

Thank you so much for the amazing course :smiley:

1 Like