Trouble installing Kaggle API on lesson 3 planate exercise

Hi - having rouble installing Kaggle API on lesson 3 planate exercise

! pip install kaggle --upgrade

installing kaggle works, then when I make a new directory, it seems to work, but when i move the .json, the file disappears from my http://localhost:8080/tree directory, but seems to not go to the right place

! mkdir -p ~/.kaggle/
! mv kaggle.json ~/.kaggle/

mv: cannot stat ‘kaggle.json’: No such file or directory


1 Like

Examine the output of this command:
ls ~/.kaggle
before and after you try to move kaggle.json.

This prints out the contents of the specified directory (in this case ~/.kaggle. Note that ~ is just a bash shortcut for the home folder. Also you can just use cp instead of mv to copy so that the file also stays in the current directory (and is not deleted from it).

Tried the command,
jupyter@my-fastai-instance : ~ $ ls ~/.kaggle


This is what i get. This means its in the right place, right? but somehow im still getting
/bin/sh: 1: kaggle: not found

I was getting the Kaggle: command not found error. I fixed this by uninsalling kaggle and reinstalling.

now getting Warning: Your Kaggle API key is readable by other users on this system! To fix this, you can run ‘chmod 600 /home/jupyter/.kaggle/kaggle.json’

Same problem here @Yorke did you fix the bug??, Can you help me out with that.

I believe running the below in the CLI solves the problem.
chmod 600 ~/.kaggle/kaggle.json

Hey guys, I’m running into a similar issue on my setup (ubuntu vm in Azure):
/bin/sh: kaggle: command not found

I tried uninstalling and reinstalling but I get the same error. The install command seems to go fine, I don’t see any errors in the output there.

Any ideas?

Did you ever figure this out? I’m running into the same thing with ubuntu vm in Azure

Same here! I ran chmod 600 ~/.kaggle/kaggle.json with no luck

I found to solve this problem you are supposed to accept competition rules (visible when entering a competition). However I wasn’t able to verify my account so I’m not sure it works.

Same problem here, solved in this topic. Good luck!