'TextDataBunch' is not defined Error - Preparing Text Data

I’m having trouble getting my data prepared for an NLP model. I get an error stating ‘TextDataBunch’ is not defined when I run the following code. I have the same issue trying to use TextLMDataBunch.

from fastai import *
from fastai.text import *

PATH =‘data/trials/’
data_lm = TextDataBunch.from_csv(PATH, ‘text_only.csv’)

I’ve been using this article as a guide and I’m not sure why I’m getting this error: https://docs.fast.ai/text.html#Getting-your-data-ready-for-modeling

Any help would be appreciated. I just completed class 4 of part 1 of the MOOC version of the class that’s currently available.

Which fastai version are you using? The guide is for fastai 1.0.+

brother did you find the solution for this

I experienced this issue on colab, I guess it’s the version of fastai installed, I solved the issue installing fastai and pytorch this way:

!pip install torch_nightly -f https://download.pytorch.org/whl/nightly/cu92/torch_nightly.html

!pip install fastai