Test_name='test' in data Error


(Kumar Shridhar) #1

Hi everyone,

As mentioned by @jeremy in Lesson 3 that we can activate the test=‘test’ to pass the test images which inside the code I can see it is None at the moment and I tried to override it but I am getting the following error:

What could be the reason for it?
I have test folder inside the path.


Wiki: Lesson 1
(Ramesh Sampath) #2

Couple fo questions -

  1. Does it run when you don’t give “test_name” or same test_name=None
  2. If it works, then can you make sure there you get results when you run !ls {PATH}test

(sergii makarevych) #3

Yep, agree with @ramesh. You might have test/test/ path instead as it is requirement for keras.


(Kumar Shridhar) #4

Thanks @ramesh

  1. It runs with test_name=None
  2. I have test folder at specified path. Test folder is empty which might be the problem. I will check that if that is the problem

(Ramesh Sampath) #5

Yeah…That absolutely might be the problem…Put couple of images in test and it might workout OK.


(Kumar Shridhar) #6

Yes I did that and it worked. Thanks for helping @ramesh


(Rahul Singh) #7

Hey everyone,

I used the code for Image classification given in lesson-1 and when I tried to pass in the Test data path, it throws the error shown above.
My test folder is in the same directory as train folder and contains images (img1.jpg, img2.jpg, …)

Any idea as to what is causing this issue?

P.S. I am using google Colab for the same.


(Rahul Singh) #8

Okay, I got this. I was using Single-label Classification model while my data set was Multi Labeled.