[Solved] Unable to read csv for kaggle santanders on google colab


I am getting error reading csv on google colab however able to the same on local machine (with anaconda-jupyter).

  1. I have successfully able to download the files from kaggle into google drive and able to do ls and see the files
  2. getting error while trying to create dataframe for further tabular processing as per lesson 3

however if I download the file locally from gdrive and do the same locally, I am able to read it (however since I don’t have fast.ai libraries locally available, I cannot do anything with it.

Any suggestions on what I could be doing wrong?


!chmod 644 train.csv


pd.read_csv('train.csv' engine='python')

this worked !

Can you tell me what did it do and why no one else seems to have faced this issue with santander dataset?

The issue was with colab. The file had no read permissions at all. chmod 644 train.csv helped you with that. 644 means that files are readable and writable by the owner of the file and readable by user.

1 Like