[Solved] Problem Downloading Images from Google Images

I am getting an unusual error while trying to download images from google images.

Error  Invalid URL '': No schema supplied. Perhaps you meant http://?

I have followed the same exact steps as suggested. I am guessing this would be something stupid that I am not able to figure out at the moment.

Here is what a few sample lines from my file looks like.


I would be really grateful if someone could help out with what I am doing wrong here. Could not find any solutions on the forum.

Also tried replacing the https:// tags with http://. No luck there.

The strange thing is that this worked for me a couple of minutes back. Does not work anymore.

Alright. Managed to get my head around it.

This was happening because there were blank lines in the ‘.txt’ file downloaded by the script. Not exactly sure why the blank lines were there. I suspect that they got introduced by Google’s dynamic “Load More” feature.

Getting rid of these lines did the trick.

As I said, it was probably something stupid that I was not able to get my head around that time.


this worked for me, thanks.

Pleasure! :slight_smile:

I am not getting any error but my images are not getting downloaded. Can you please share your exact file which contains urls?

1 Like