Setup problems: AWS


Thanks a million!!! I made several changes, it looks like it’s working now! wow, I am in tears. :slight_smile:


I’m also experiencing the ‘aws configure get’ command not recognized (Windows 10 with Bash)

(windalfin) #903

Hi all,

I tried configuring AWS and in the process created 2 instances. I terminated one of those instances since I won’t be using it anymore. However when i use aws-get-p2 I always get the first instances. instead of the second instances where I haven’t terminate. Is there anyway to change where the alias pointing?

Before creating the second instances I already terminated the first instances, the EBC connected, the keypair.

can anyone point out on how I can solve this?

(Navin Kumar) #904

The output you got is expected… The images put in the vm have recent cuda drivers with an older thenao version. The notebook should run fine even with that warning…

Jeremy explains the same in his Lesson0 video. kindly do have a look at that…


Hi. Did you ever get this working on cloud9?

(Gaurav Rele) #906

can you paste your error that you are getting, if you are terminating the first instance you can typically do something like this to get the ip address of your running instance

This is my version of the fastai alias. for example you can use the instance id from your second instance to start and stop it once you have created it the first time.

alias startfastai='aws ec2 start-instances --instance-ids i-0b4273d97bd4a1cfa --region us-west-2 --profile grele’
alias stopfastai='aws ec2 stop-instances --instance-ids i-0b4273d97bd4a1cfa --region us-west-2 --profile grele’
alias sshfastai=‘ssh -i /mnt/c/Users/grele/Downloads/gaurav-work.pem -L localhost:8889:localhost:8889 ubuntu@$(aws ec2 describe-instances --profile grele --region us-west-2 --instance-ids i-0b4273d97bd4a1cfa --que
ry ‘Reservations[].Instances[].PublicIpAddress’ --output text)’

hope it helps.

(VamshiKrishna14) #907

Very usefull information…

(Justin ) #908

Nope! Are you trying to do it or did you find a way to do it?

(Hugo) #909

Thanks for your answer! :slight_smile:

(windalfin) #910

Thanks, Nell, Looking at your example is very clear. I should be able to edit my Alias to point to specific instance.

The issue actualy has been resolved after AWS removed my terminated instances. I think the alias is reading the first instances in my ec2 not any specific instances.


I also had the same problem and could not resolve it. I decided to use the solution that was recommended somewhere above. I have yet to find out how to navigate this forum so below are the notes I wrote at the time on what I did
Brief instructions on setup

  1. cygwin did not work so use windows bash


    Then ‘sudo apt-get install python-pip python-dev build-essential’ then ‘pip install awscli’

    rightclick the top left and tick easy edit under options to allow right button copy AND paste

  2. then run aws configure and add the
    Access key ID :
    Secret access key :
    out put is text (lowercase)

  3. Need and from:

    The quickest way is to copy the raw content
    then sudo nano filename and rightclick

  4.  ssh in as above
  5.  sudo rm .bash_history

    jupyter notebook


Yes, I got it working. I’m using a Google Cloud backend though. And I’m still on the first lesson but so far so good. I noticed Jeremy in the videos uses tmux. I don’t recommend messing around with tmux. Cloud9 already uses tmux for it’s tab system so you’ve got the benefits of tmux already.

I set it up on Google Cloud (because of the free $300 credit ) using this tutorial.

(Justin ) #913

Thanks for the tip! I’ll look into it!

Good luck!

(KRO) #914

How long are people waiting for aws to set up an EC2 p2.xlarge instance these days?

(KRO) #915

ok - it still takes under 24 hours! This might help someone else.

(KRO) #916

OK, the AWS user setup interface has changed since the setup video was made. Is there a place to go to find out what “permissions” the first user should have? It’s hard to know without knowing the ins and outs of aws yet. Thanks!

(KRO) #917

Hmm it seems like is a good resource, but here’s a question about setting up the Administrator user. Why don’t they recommend checking the “Programmatic Access” box? Wouldn’t you want the administrator user to have all permissions? Or is the idea that the Administrator user doesn’t need to do anything requiring programmatic access; those tasks should be done under other accounts?

(brindha) #918

I am facing the same error. Can you let me know how you proceeded

(Raghavan) #919

After correcting all sorts of errors, my runs fine now. But does not get executed completely. Below is the output.

> $ bash
> Only us-west-2 (Oregon), eu-west-1 (Ireland), and us-east-1 (Virginia) are currently supported

I tried getting the region in aws configure and it looks fine.

    $ aws configure get region

But still my does not do the intended job. I have just started at Any help please?

(Raghavan) #920

Anyone using a NSCC HPC from Singapore? Can someone guide with the steps to configure it for running Deep Learning libraries?