Setup problems: AWS

(Gautam Karmakar) #881

Is there any step by step guide to configure instance after it is launched and running?
Can anyone who did it successfully share screen-shots or command etc?

Thanks in advance…


I also have the problem that when I try to run aws, I get the error message,

“C:\Users\535390\AppData\Local\Continuum\anaconda2\python.exe: can’t open file ‘/cygdrive/c/Users/535390/AppData/Local/Continuum/anaconda2/Scripts/aws’: [Errno 2] No such file or directory”

I have tried out several of the suggestions given here including uninstalling awscli, reinstalling it, setting PATH etc. but even after all of these I still get the same error message.

Perhaps the problem is compounded by the fact that I am out of touch with Unix / Linux having worked in Windows environments for the past 5 years.

All help appreciated. Thanks

Vivek (A different Vivek from Vivek1 :-))

(Aman Dalmia) #883

"750 hours of Amazon EC2 Linux t2.micro instance usage (1 GiB of memory and 32-bit and 64-bit platform support) – enough hours to run continuously each month*"

They have mention in there site

(Aman Dalmia) #884

I had wasted my entire day and finally gave up.

(Michelle Bonat) #885

@jeremy this is a great course … but me and some others are recently blocked on setup and aren’t drawing responses. Can you please have a member of your team respond to my issue post and the others? Thanks.

(Sathvi) #886

HI… I’ve successfully completed AWS setup in t2.micro instance . But When I try to access ec2 instance via browser using public dns it shows server is not connected. Jupyter notebook is running in 8888 port.

I also tried using ping command but it shows request timeout.

(Navin Kumar) #887

Could you wait for a few minutes after you type the command ‘jupyter notebook’.
The log of the command should contain similar to the line below at the end of the log:
“Jupyter notebook is running on all ip adresses on port 8888 ( press Ctrl-C twice to shutdown the kernel).”

You should wait to see the above line. If not then the jupyter notebook is still trying to initialise and you have prematurely asked it to open…

hope it helps

(Navin Kumar) #888


If you are running a t2 instance, the log is correct, because t2 instances do not have GPU.

If you run into the problem with a p2 instance, run the command
$nvidia-smi to see output similar to lesson0 server setup video of jeremy .

Also see the if you run into problems.

hope it helps

(John) #889

I run the scripts aws-get-ps, aws-start, and aws-ssh. Everything seems to work. But I then get prompted for a pw:

Enter passphrase for key ‘/home/john/.ssh/aws-key-fast-ai.pem’:

I’m not sure what to enter her, and when I type nothing appears and the cursor does not move. I tried typing anyway, and entered the PW I saved from the AWS install video, but when I hit enter the prompt displayed again. In lecture 1 there is no discussion about a password. Should I need to enter a pw here? If so, how? If not, why am I getting this prompt? Any help greatly appreciated.

Also, in case it matters, there is no file “aws-key-fast-ai.pem” is dir .ssh. There is however a file named “aws-key.pem”. I copied aws-key.pem over to aws-key-fast-ai.pem. Hopefully that was the correct fix for the reference to aws-key-fast-ai.pem in the aws-ssh alias.

Edit: I also noticed that aws-key.pem is an empty file. Is it supposed to be empty?

Edit 2: I deleted all instances using the AWS dashboard and started over. I ran which seemed to run correctly. From the dashboard I can see that I created an instance and it is running. However, when I attempt to ssh in I again get the prompt to enter a passphrase, although it does not appear that I can enter any text at the prompt. And I’m not sure what I would enter, anyway.


(prajna_rai) #890


I am getting this error when giving aws-start
An error occurred (InvalidParameterCombination) when calling the StartInstances operation: No instances specified.

Please let me know how should i proceed

(Roger Jennings) #891

Need some help on what seems to be a common problem. I have followed the propsed solution but still have an issue.

I get the following error message:
C:\users\Roger\Anaconda2\python.exe: can’t open file ‘/cygdrive/c/Users/Roger/Anaconda2/Scripts/aws’: [Errno 2] No such file or directory

I already had python installed but followed the instructions to install it in the cygwin directory. (

So, echo $PATH shows the above process changed the python directory as desired where python is in cygdrive path: /usr/local/bin:/usr/bin:/cygdrive/c/ProgramData/Oracle/Java/javapath:/cygdrive/c/Windows/system32:/cygdrive/c/Windows:/cygdrive/c/Windows/System32/Wbem:/cygdrive/c/Windows/System32/WindowsPowerShell/v1.0:/cygdrive/c/Program Files/MiKTeX 2.9/miktex/bin/x64:/cygdrive/c/Program Files (x86)/QuickTime/QTSystem:/cygdrive/c/Program Files/MySQL/MySQL Utilities 1.6:/cygdrive/c/Users/Roger/Anaconda2:/cygdrive/c/Users/Roger/Anaconda2/Scripts

However, when aws configure runs from the script, it still picks up the windows python path (C:\users\Roger\Anaconda2\python.exe) as shown in the error message.

How is this addressed? BTW, I am a linux user from work but this half windows, half linux is pretty frustrating. Hope to move past it soon into the course…

(Jorge Barriga Partarrieu) #892

Beginner problem setting up Mac
Trying to run with script from the Github page using wget in my terminal, but to no avail.
I then tried to copy the code and start a new script file in Xcode, saved it in the root folder and tried to run using bash, but also not working.
Currently waiting for instance to open to be able to install
Are these related?
Many thanks to anyone who can point me in the right direction.

(Jorge Barriga Partarrieu) #893

sorry, I can get the script with wget, but get the following error:
Jorges-MBP:~ jbarrigapartarrieu$ bash line 7: syntax error near unexpected token newline' line 7:

(Jorge Barriga Partarrieu) #894

"Hello World!"
If this is of help to anyone, a few pointers:

  1. I re-created the scripts from the course’s Github page and saved them to the root folder ~/User/
  2. Make sure the the region you choose when setting up aws (aws configure) is the same as in your AWS Console
  3. Make sure you have a folder called .ssh in the root folder (as in #1 above)
  4. If you have already tried and gotten an error message, check out following before you try again:
    a. Delete the aws-key.pem file in your .ssh folder
    b. Delete any VPCs in your AWS Console
    c. Delete any Elastic IPs in your AWS Console
  5. Run the bash script from the root folder (as in #1 above)

Good luck!

(Hugo) #895

Hi sam. Hey, I’ve got the same problem:

Using gpu device 0: Tesla K80 (CNMeM is disabled, cuDNN 5103)
/home/ubuntu/anaconda2/lib/python2.7/site-packages/theano/sandbox/cuda/ UserWarning: Your cuDNN version is more recent than the one Theano officially supports. If you see any problems, try updating Theano or downgrading cuDNN to version 5.

Were you able to solve it?

(Hugo) #896

I’m getting this error:

(Hugo) #897

I’ve fixed the part with the error related with vgg16bn not being there (I had to copy to the nbs directory), but not the one in pink.


Does anyone have a fix for this? I’m also having this problem.


Happy thanksgiving everyone!
Can anyone help? I am about to give up, I think I did everything already.
I restarted the aws and still get the following error:
$ bash

An error occurred (InvalidKeyPair.NotFound) when calling the RunInstances operat ion: The key pair ‘aws-key-fast-ai’ does not exist

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start…

Waiter InstanceRunning failed: Waiter encountered a terminal failure state
usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help
aws help
aws help
aws: error: argument --instance-id: expected one argument

An error occurred (MissingParameter) when calling the RebootInstances operation: The request must contain the parameter InstancesSet

All done. Find all you need to connect in the fast-ai-commands.txt file and to r emove the stack call
Connect to your instance: ssh -i /c/Users/gfeng/.ssh/aws-key-fast-ai.pem ubuntu@

(Gaurav Rele) #900

I think its probably happening because the keypair location is different from where you have it. The original file in the github calls for ~/.ssh/ but since you are on windows you might need a different path. Another thing might be the use of / where you might need a \ for windows. Hope this helps