Setup problems: AWS


Hi all,

I also have another bug confused me. When I run jupyter notebook on my t2.micro, I cannot link by the notebook by https://ip:8888 or https://dns:8888 on my local mac.

then change login method by
sudo ssh -i ~/.ssh/aws-key.pem -L 443: ubuntu@ip

and I type https://localhost. I guess my local browser might link the notebook, since t2.micro logged the follow info:
[I 08:09:43.518 NotebookApp] 302 GET / ( 0.53ms

and let me input password which I have set by openssl. However, the notebook page is waiting all the time and cannot by used after I type password.

That’s really confused me a long time. Can someone give me some guide?


(姜维克) #777

I have questions to ask. macOS python3.6
export PATH=~/.local/bin:$PATH source ~/.bash_profile aws --version
result:aws not found

(Pinku Deb Nath) #778

Hello :),
I think p2.xlarge instance is removed from the services provided in AWS. Which one should I select?

(noskill) #779

open the cygwin and move to directory /users/erik/
then type

chmod 700 .ssh

now permission denied error will go away. and i recommend you start from scratch i.e. delete all instances,elastic ips, vpc , rm .ssh/aws-key.pem etc.

this should work.

(Disha) #780

Hi! I am using Mac OS X, I was able to get through the set up fine following the youtube video.
However, I am failing to open the jupyter notebook on the browser. It says, “This site can’t be reached”.

How do I resolve this issue?

Thanks in advance!

(Saurabh Mittal) #781

What’s the IP address you are using, you can either get the IP Address again using the aws-alias script or you can go to and check out the IP Address that would be listed under the running instances.

(Saurabh Mittal) #782

You probably need to do a pip install aws or sudo-apt ?

(Saurabh Mittal) #783

p2’s need to be requested specifically from Amazon by sending an email to AWS Support as per the annotation in the youtube video.

(Disha) #784

Thanks @sam_codes for the response.
Using the instance ip address, which looks like…

(Saurabh Mittal) #785

Hi, perhaps start it all over if you haven’t been able to connect even once? If you had been able to connect previously then I would have thought that it had to do with more than one entry against Elastic IP’s or other stuff that is under Instances or EBS when you login to the console at AWS.

(Saurabh Mittal) #786

perhaps try using the direct IP address that would be listed when you see your instance (see the green highlighted section below)

(Disha) #787

It worked on restarting, thanks!

(Saurabh Mittal) #788

Great stuff and all the best !

(Saurabh Mittal) #789

Hey Rajat, hope it’s not some sort of a firewall issue? Are you accessing this from work/university etc or from your home?
You could perhaps try doing a tracert etc to figure out where exactly it fails…


I filled out my upgrade request as instructed (p2.xlarge, MOOC, etc.) but was denied by Amazon. Is the agreement no longer in place? What’s the best alternative, if Amazon is now a no-go?

(Boris Gotzev) #791

Hi - am trying to download the scripts from github but am getting an error:

ERROR: cannot verify’s certificate, issued by ‘CN=DigiCert SHA2 High Assurance Server CA,,O=DigiCert Inc,C=US’:
Unable to locally verify the issuer’s authority.
To connect to insecurely, use `–no-check-certificate’.

Anyone know how to fix this?


I would like to setup the t2 instance in the Ireland region.

ami-f8fd5998 is for the us region - is there a t2 ami for the Ireland region?


(Edward Flaschner) #793

Sorry if I am in the wrong spot as I cannot find the right place to ask this question. As often happens to me in MOOCs, I can’t get past the installation. I used Cygwin to install awscli as instructed and then when typing $ aws, I get
$ aws
-bash: /cygdrive/c/Users/Edward Flaschner/AppData/Local/Programs/Python/Python36-32/Scripts/aws: c:\users\edward: bad interpreter: No such file or directory

I tried the wiki to fix the problem but no change. Can anybody please help?



I’ve been having a weird setup problem. I’ve gotten to the point where I am running the aws configure command in the bash console but I think somehow it has broken. I think the problem is that I’m not able to actually configure the server.
So I’ll type in the values to set it up like so

Everything looks normal except for the default region name: for some reason it says that the value it has right now (in the square braces) is what is typed in 2 lines above previously. I think that somehow the file that holds this data got screwed up and it won’t allow me to change that. i’ve done this 10+ times and all the other data in the [] will update but that one one it still shows "AWS Access Key ID [***************5XWQ]: asdlfasdfasf: instead of like “us-west-2”.

And i think this leads to my next problem which is that I when I try to connect to set up the server that same string of AWS Access Key ID shows up again. like this

Link to image because they only allow one image per upload :frowning:

So I believe somehow my config file got screwed up and there are just random lines of input text all over my files so that I can’t login to connect to anything.

I’ve tried uninstalling and reinstalling awscli and that didn’t seem to work. If anybody knows of any ideas of how to make this work or how I can reset this file/ these values I would love some help

-Nick Karlovich


try this

and if the uninstall takes forever just skip it