Setup problems: AWS

Can we use the free aws outside of US or Europe? Each time I ran “bash”, it always appears:

Only us-west-2 (Oregon), eu-west-1 (Ireland), and us-east-1 (Virginia) are currently supported

Anyone knows how to resolve this? Thanks a lot!

sorry, I forgot to mention that I’m in Hong Kong:-)

Hi @chenwk891,

At the moment those three regions are the only ones that have p2 instances available.

oh I see! then any method to get free license? Thanks! @z0k

Hi @jeeyung,
What error message are you seeing? What operating system are you using? Please see here for advice on how to ask for help :slight_smile:

The p2 instances are not available for free, unfortunately. But you can try using spot instances to cut down on costs quite dramatically; have a look here and here.

I reinstalled all and tried, but still the same error. Not able to solve anymore. Please help

$ bash line 7: syntax error near unexpected token newline' line 7:

$ bash line 7: syntax error near unexpected token newline' line 7:

Thanks, Zarak! @z0k

1 Like

Hi @Girija,
Did you try what I described in an earlier post?

This might be a trivial thing but I can’t seem to figure it out.

I always have to type aws.cmd in cygwin to do anything. I thought this would be an irrelevant issue but it’s getting really tedious trying to change all the scripts to compensate for this issue I have.

When I type in aws, I get this:
“C:\Anaconda\python.exe: can’t open file ‘/c/Anaconda/Scripts/aws’: [Errno 2] No such file or directory”

Only when I type in aws.cmd do I get this:
"usage: aws [options] [ …] [parameters]
To see help text, you can run:

aws help
aws help
aws help
aws.cmd: error: too few arguments

In bash, when I run the command “bash” I get the following error and cannot set up my server…

I am unsure how to proceed.

Hi @Dan195,

That’s strange. Can you let me know what you see when you type the following command in bash

whoami && ls -ld ~ ~/.ssh

Hi @murmur,

I don’t have a windows setup at the moment to test this, but did you try any of the solutions offered here?

edit: I also just saw this solution on the wiki-page.

It’s saying “No such file or directory”.

What does it say for ls -ld ~?

I’m wondering if it’s a permissions issue. It would help if you could copy and paste the output - on my Mac it looks like this

drwxr-xr-x+ 123 zarak  staff  4182 19 Mar 10:08 /Users/zarak
bash-3.1$ ls -ld ~
ls: /home/Peter: No such file or directory

Oh, I see, it seems that the user was created without a home directory. Try running this command

mkhomedir_helper Peter

You’ll probably also need to run aws configure to create your .aws subdirectory under your home directory.

the “mkhomedir_helper” command cannot be found. Would it be a bad idea to create a “home” folder in "C:: and then cut “Peter” into that location?

Sorry, I don’t know why I assumed you were on a Linux system. I’m afraid I’m not familiar with bash on Windows, though you can certainly try creating your home folder manually.