Setup AWS for Part 1 V2

Requesting help setting up a p2 instance running Ubuntu 16.04 on AWS.

I know that is now obsolete(lots of version changes since then) and although there’s a setup script for Paperspace, it’ll not work on AWS instances.

BTW, I had setup a p2 instance with V1 specific libraries(theano and everything) earlier and came to know about V2 just now.



We’ve built the runtime environment for the V2 part 1:

Уou can install it on AWS on Ubuntu, Amazon Linux or CentOS. If you want to install on Ubuntu, you need to launch standard Ubuntu 16.04 image, then log in as ‘ubuntu’ user and run the installer from the command line (

We’ve tested it on the AWS g2’s and some Azure and GCP machines, but I’m sure it will work on a p2 instance as well.


Please provide information if these appliances are free or are paid? Will greatly help community.

So after some trials, I guess I have got it setup just fine.

I combined V1 install script and paperspace install script and came up with a working install of everything.

I’ve also uploaded it and can be downloaded from here. It has worked for me so far, but I experienced that the model training took like 1.30 minutes where it worked for Howard in seconds. Feel free to review and correct it.

I’ve also created an AMI with this setup in Ohio region for further use. Ping me if anyone wants to use it, I’ll make it public.


Yes, all these appliances are free

1 Like

So if I understand correctly, once this is installed on my machine ( Titan X) I can run all the code and examples locally without needing to setup the AWS or paperspace? Thanks.

That’s right, it can be installed locally also

Thanks for your answer. I have one last question: I thought this was the new version (v2) of the deep learning class but the notebooks seem to be different than the notebooks shown on the course videos. Is there something I misunderstood? thanks again.

The courses are cloned as is from the fastai github repo. You can see in the working dir /jet/prs/workspace the subdirectory ‘fastai’ - it’s the cloned repo. So V2 courses are located in the ‘fastai’ - the ‘courses’ subdirectory

1 Like

Hi! Coming back after a while. The jetware machine worked perfectly for about 8 months but now It’s not able to acess the GPU anymore. ( torch.cuda.is_available() returns false while it used to return true before.) I wanted to remove the machine and reinstall it again but I can’t find how to do it on google =) Anyone has any idea? Also if there is a fix for the cuda problem without removing the environment I can use that as well. Thanks again.