Seting up an Azure VM for DeepLearning

just follow the tutorial and go to local:8000 in your browser
I followed this tutorial to setup a VM for this course but I cant load the notebook,I have access only to azure and I hope I can do this course ,this is the most practical course I have ever attended.
1 Like

Hello, I followed the steps in the tutorial. How do we access the remote notebooks? I tried localhost:8000 and local:8000 on my browser(google chrome). Both approache gave me “site cannot be reached” response. Also, i tried remote_ip:8888 in my browser. Kindly help

i’m not sure what you tried. but once you have the server running you have launch the notebooks from from the terminal with jupyter notebook command to serve the notebook pages whether on your local machine or on the remote server.

Check your network security group. Most likely this is under name of server-nsg. You should create an inbound security rule for TCP that opens up to port 8888

Hello Melissa. I typed in jupyter notebook on the remote machine. I was having issues with tunneling. I was able to solve it. Thank you for the response :slight_smile:

Hello Sean, thank you for the help. I’m up and running now. Cheers.

I faced issue after running Azure installation script for configuring the jupyter notebook.

Original Script Path:

Last few lines of code gave error:
echo “c.NotebookApp.password = u’”$jupass"’" >> .jupyter/
echo “c.NotebookApp.ip = '*'
c.NotebookApp.open_browser = False” >> .jupyter/

echo “c.NotebookApp.password = u’”$jupass"’" >> .jupyter/
echo “c.NotebookApp.ip = ‘*’” >> .jupyter/
echo “c.NotebookApp.open_browser = False” >> .jupyter/

I ran the script on Azure and run $ jupyter notebooks, the login url opens, but the dl_course does not works as valid password! I have tried also copying the password. Is there an issue about the password on Azure VM?

Ok, I gave up on my VM and deleted it and created a new VM and run the installation script again. This time, I was prompted to set a password for jupyter! (I was not prompted first time and I assumed that the dl_course as the password is hardcoded in the jupyter config file). I set the password to “dl_course” and without any other problem, I could run the jupyter notebook command and access the portal on my browser and use the password to login.

hi, i am prompted for password and i did set it. However when i run “jupyter notebook” command on bash console it says no such command. even on browser when i access [public_ip]:8888, it says refused to connect. I have the configured the nsg rule for 8888 to be allowed. Any help?

restarted the machine and i worked!! Dunno the issue.

How did you tunnel to your azure machine? I put a public IP on my VM but I can’t seem to reach it… I’ve also set the NSG inboud to 8888…

When I enter my IP http://IP:8888/?token=cfa99dxxxx… it says the site can’t be reached… checking my network interface in ubuntu… i’m unable to see my IP… which I believe is normal for Azure…

Any help is appreciated, thanks!