Set-up on Windows Server Thread


(Gregor) #1

Hi - I’m trying to set up fastai on Windows Server. After following the instructions at Howto: installation on Windows I was able to get it to work, however I did require an admin login to replace the linux simulink with a windows one (see step 8 on that link). This was expected though as our computers are not in Developer Mode and therefore do need admin access for a step like this.

After doing this, I ran lesson 1 and was able to run the notebook, in full (yay!).

However, today after logging back in as a user, I tried to run it again and got the following permission error:

Does anyone know how I can work around this without explicitly needing administrator access? We will most likely have 3 or 4 people on this server using fastai.

This is what I suspect to be true about the situation:

  1. It worked yesterday only because I was running Anaconda Prompt as admin (to complete the simulink step), and then ran jupyter notebook from that prompt after activating fastai
  2. I therefore had admin privilege when I tried to create a learner, and was thus able to access C:\Windows\system32\config\systemprofile/.torch
  3. I can test this hypothesis by again asking for an admin login and seeing if it works, but assuming that this is true (as it worked yesterday), is not the solution.

What I don’t know about the situation:

  1. Why exactly is it the case that I need admin privilege for …/.torch
  2. If it’s possible to change admin rights for that, and if it is, I don’t know if that will solve the entire problem (Perhaps there are other things a User doesn’t have access to that will cause failures somewhere else down the line).

One note: I’m able to get admin rights if I need it, so if there are solutions that require admin rights I can do it, as long as it’s not the case that one would need admin rights every time they want to work.

Edit 1: One thing to note is that Anaconda isn’t installed in my home dir, which has a tendency to cause permission problems. We have very limited space on our C: Drive so I made the decision to install Anaconda + fastai elsewhere. At this point I don’t know if this is the issue. It seems to me that if it was in my home dir, I would still (as a user) not have access to …/torch in system config