School of AI Beijing Study Group

This is the study group for the fastai course as part of the School of AI Beijing.

Relevant assignments will be updated in this post.

April 15 Meetup — Lesson 1 review

Pre-Meetup Homework

Useful Links

14 Likes

Hello :smiley:

1 Like

hello. OK.

1 Like

Nice to be here. Let’s study hard guys!

1 Like

Wishing everyone good luck!

1 Like

Yay, I’m in! :slight_smile:

1 Like

Hello!

1 Like

It takes too much time to train a dataset on google colab. I don’t know if it’s okay speed or not. Is there a way to check a speed of training a dataset?

First, you need to enable GPU in Colab notebook:

11%20AM 19%20AM

Then, to see if that worked, try this code in your notebook:

import torch
torch.cuda.is_available()

If it prints False it means it is not available.

it’s True. Trains much faster.
However it’s still slow I suppose. is there a way to check a speed of model training and test the speed against other GPU survices???
it’s 25 min per epoch, if 4 epochs , it’s basically almost 2 hrs. Having very unstable internet connection here in China, my first attempt to train on dataset was unsuccessful, I lost internet connection((((((.

Hellomeow! :upside_down_face:

2 Likes

I already trained my fastai model on dataset and saved weights (learn.save(‘stage-1’), but every time I open google colab notebook, I need to do training all over again, how to avoid it and access trained model for interpretation???

If I run it in Jupyter notebook on my laptop, can this help?

Hi everyone - looking forward to tackling fast.ai with you over the next little while!

Has anyone been using Crestle for notebook and GPU? It was working perfectly for the past week, but today I keep getting a “Page not found” error when launching the course session. I’ve emailed support but was wondering if anyone has had a similar issue? Cheers!

Nevermind, all working again!

I am now starting to do the image dataset classification for further deep learning courses.

page not found happened to me as well. My problem was that I had no money on my bank account I linked to creste.ai. As long as I charged my bank card again, it worked!

I’m usiing colab with GPU enabled.
learn.lr_find() sometimes prompted the message with red “Interrupted” but disappears next, so I can not get a screenshot of it.
but learn.recorder.plot() after it still can show…

Anyone saw this and know why it is?

It might be a problem on the sever side. I am not sure how to solve it. If learn.recorder.plot() still shows the output, then it should be fine and you shouldn’t worry about it.

@Max Hey…plz dont forget to share on how to plot the Train/Valid loss.vs epochs

Thanks

oor Never mind. It is actually explained in lesson 2.

Cheers.