Sagemaker Template setup

I can’t find the initial cloudformation template that is used for creating the sagemaker notebook. Can anyone send me a direct link to the template.

Which guide are you following?

Have you tried

I also tried to do the same by following steps in
But the template URL for cloud formation is also impossible to read. And I am wondering if anyone has the URL somewhere that we can copy and paste. Or Do you recommend I created it from scratch?

@mariokostelac BTW, the link you provided also indicates we should follow instructions in instead. I did find a template in

Its is close to the official doc but still not so sure I should use that since I did see some hardcode ipaddress in that template file. I am wondering who can clarify this.

@gnchen Ah sorry did not see the update. I just remember I set it up like they advised (the old, manual version).

Hmm. I just clicked on the yellow button for the region I wanted. Here is the link for Ireland region. That should open prepopulated form with URL.

Edit: If that does not work, stack url is

1 Like

Thanks for the tip. I actually though that is just pic

No, it just looks ugly and not clickable (at least on my 4k display). User experience and visual design are not first class concerns for AWS, but their machines do work :slight_smile:.

1 Like

I used the template and launched a notebook but the notebook does not have the materials, it’s just a blank environment. Has anyone seen this?

@matthewarthur I had the same issue. the Jupyter notebook was blank.

1 Like

Did you move to ec2 or colab?

@matthewarthur and @KeeganJustis Have you navigate to Sagemaker example tabs and see additional examples for fastai course v3? You will need to make copy from there.

It takes around 10 min to setup the fastai conda environment when you create the SageMaker notebook instance so that is why the folder is blank. It only takes this amount of time on creation as the conda environment is saved between notebook restarts.

You will know when it is ready when the Jupyter kernel name Python 3 is available and a ‘course-v3’ folder appears in your Jupyter Notebook window.

Hi, I’m trying to create the sagemaker stack. Thanks @matt.mcclean, used your template.

Stack Creation Fails.

“The account-level service limit ‘ml.p2.xlarge for notebook instance usage’ is 0 Instances, with current utilization of 0 Instances and a request delta of 1 Instances. Please contact AWS support to request an increase for this limit. (Service: AmazonSageMaker; Status Code: 400; Error Code: ResourceLimitExceeded; Request ID: ec9dcedf-ff0d-4d8b-8ad4-5d930fdc6e67)”

@matt.mcclean Hello Matt, I have the error msg of ROLLBACK_COMPLETE by using your template, no notebook instance was created in SageMaker. Could you advice on the solution please? Thanks very much!

1 Like


AWS support could take 24 - 72 hours to lift up the instance limit and the AWS support could reject the request too depending on the regions. If you guys want to use the template immediately, I just wrote down the instruction to switch to a smaller instance available in your account. Please note that could affect the performance. Have fun!

Hi guys, We just added support for fastai with BentoML(

BentoML is open source library for packaging, shipping and running ML services.

After you package fastai model with bentoml, just one command, it will deploy to services like Sagemaker or AWS Lambda

$ bentoml deploy /path/to/service --platform=aws-sagemaker

You can check out the example at