SageMaker Deployment Error

Hi all,

I’m trying to set up SageMaker to work through the examples and experiment with the code.

A month ago I was able to successfully provision a SageMaker notebook instance using the provided CloudFormation template (us-east-1). However, I’m now getting an error message (see attached screenshots) when I’m trying to replicate this setup in a different AWS account. I’m not sure if there were any major changes in the meantime.

Any help or guidance would be greatly appreciated!

Thanks in advance!

lh372

I just created one using the cloudformation template on the fastai tutorial, and it seemed ok. I can access the notebooks. I don’t see the option for a fastai kernel anymore, so tried the pytorch_p36 one which seems ok, keeping in mind, I had to pip install the fastbook

Thanks, Matthew! I appreciate your response!

I was able to get it to work by making a small change to the CloudFormation template (add the ‘–ignore-installed’ option on line 100):
pip install --ignore-installed -r /home/ec2-user/SageMaker/fastbook/requirements.txt

2 Likes