Running Docker Image (Apple Silicon / Fastai2.5)

Has anyone had success with Jeremy’s post to Twitter …
This Docker Image:

I try running this on Sonoma-beta, with M2 … and just exits.

Are there specific optional params needed to get this image running stably ?

Thanks in advance for the reply.


I have worked this to the point I can get a prompt now …

you need to run this from command line:
assuming you tag the docker image as dl2

docker run -it --init dl2  

can give you a prompt for the docker container …

I have not evaluated if this will run on the GPU …

will report on this later :wink:

1 Like

This works to launch the container however …

docker run -it -p 8888:8888 --init image_name 

This still does not allow jupyter notebook access

any ideas ?

I have tried to no avail:

docker run -it -p 8888:8888 --expose 8888/tcp docker_image

I would really like to make this server a Jupyter Notebook …

But cannot seem to get the Fastai2.5 M1 image to serve a jupyter notebook.

I understand how to do this now:

Host machine: docker run -it -p 8888:8888 image:version

Inside the Container : jupyter notebook --ip --no-browser --allow-root

Host machine access this url : localhost:8888/tree‌​

When you are logging in for the first time there will be a link displayed on the terminal to log on with a token. You can also use the tokenized link.