Remote Jupyter access of home DL rig

Heya all,

I finally managed to successfully follow Jeremy s instructions to create my home brew DL rig but I’ve hit a bit of an odd problem, I can’t seem to access the jupyter notebook from my laptop (i.e. from my couch) when running the jupyter notebook on the desktop.
Obviously I can remote into the desktop and do it that way but ideally I’d like to just open up a browser on the laptop and give it the old :8888. I’m assuming the answer is buried in the config file but i’m struggling with the jupyter documentation.

Thanks in advance

Do you get an error message, or does it just time out? If you’re on the same network it shouldn’t be a problem unless you’re trying the wrong address, or the host has something blocking the port. I’d look at those before any jupyter config.

So I have four lines of configuration in my ~/.jupyter/ and am sitting with on my couch with my laptop:

c.NotebookApp.base_url = '/my-ipython-url'
c.NotebookApp.ip = ''
c.NotebookApp.open_browser = False
c.NotebookApp.password = 'sha1:not_really_this_text'

You might get by without 1 and 3, but this works best for me. There is a utility to get the password string, but I forgot the exact name - but there are lots of comments, too.

The other thing I had to solve was reconnecting to jupyter notebooks (I was annoyed at loosing too much output) - I solved that with really hacky modifications of Jupyter Notebook itself. (It will complain about a too high message rate if you run output-intensive notebooks and reconnect, though.)

Best regards


how exactly are you connecting?
I for example did this by my home wifi, just needed to assign IP for my box (by forwarding on router), and then just simply “jupyter notebook --ip: XXX” where XXX is box local IP.

Oh, and you should setup a password, otherwise I think you would have to enter token.

You can set up an ssh tunnel to forward port 8888 from your DL rig to your laptop:
ssh -N -f -L localhost:8888:localhost:8888 user@dl-rig-ip-address. See the “Outside access” section of this article for more info on how to get that set up.

Thanks for a quick reply @digitalspecialists but by the time I got around to answering you the other guys had chimed in. It seem the answer is that Jupyter itself was blocking me.

Ok guys, first off thanks for your quick replies. I had actually tried a few of these things but with no success but I may have mis-understood some of the instructions when taken out of context.

So: Gold medal for simplest answer goes to…@sayko, quick and dirty from the conda CLI (but I did need a pre-set password).
Silver Medal for basically the same answer but less CLI and more config file (aka, the longer term solution) goes to @t-v
Finally the bronze medal for what may be the best (and most technically correct) answer goes to @wdhorton, I’ll use this option eventually but ssh is only easy on linux (or mac, i dunno).

Thanks to all of you for helping me out

1 Like

I’m Using ngrok. It works like a charm and able to access it from outside lan aswel. Have look at my blog.

you can look at the section " Making your system accessible from internet"